Closed Bug 1275974 Opened 3 years ago Closed 3 years ago

Notifications should use displayMessage

Categories

(Thunderbird :: Instant Messaging, defect)

defect
Not set

Tracking

(thunderbird46 wontfix, thunderbird47 fixed, thunderbird48 fixed, thunderbird49 fixed, thunderbird_esr4547+ fixed)

RESOLVED FIXED
Thunderbird 49.0
Tracking Status
thunderbird46 --- wontfix
thunderbird47 --- fixed
thunderbird48 --- fixed
thunderbird49 --- fixed
thunderbird_esr45 47+ fixed

People

(Reporter: arlolra, Assigned: arlolra)

Details

Attachments

(1 file, 1 obsolete file)

Attached patch notification.patch (obsolete) — Splinter Review
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.63 Safari/537.36

Steps to reproduce:

Received an encrypted message


Actual results:

Notification showed the ciphertext


Expected results:

Displayed the plaintext
Attachment #8756920 - Attachment is patch: true
Attachment #8756920 - Attachment mime type: text/x-patch → text/plain
Attachment #8756920 - Flags: review?(aleth)
Attachment #8756920 - Flags: review?(aleth) → review+
Comment on attachment 8756920 [details] [diff] [review]
notification.patch

Review of attachment 8756920 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch! Can you add the equivalent change for TB too? Probably in
https://dxr.mozilla.org/comm-central/source/mail/components/im/modules/chatNotifications.jsm
Attachment #8756920 - Flags: review+ → review?(aleth)
Attachment #8756920 - Attachment is obsolete: true
Attachment #8756920 - Flags: review?(aleth)
Attachment #8756935 - Flags: review?(aleth)
Comment on attachment 8756935 [details] [diff] [review]
notification.patch from c1

Review of attachment 8756935 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!

More forked code that should probably be unforked...
Attachment #8756935 - Flags: review?(aleth) → review+
Keywords: checkin-needed
Is this worth uplifting to ESR?
Assignee: nobody → arlolra
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Not sure what the bar is on that, but I think so.
Component: Other → Instant Messaging
Product: Instantbird → Thunderbird
Version: trunk → unspecified
Now it's landed, you can request uplift.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 49.0
And how do I go about doing that?
Comment on attachment 8756935 [details] [diff] [review]
notification.patch from c1

[Approval Request Comment]
Regression caused by (bug #): bug 983347
User impact if declined: Potentially unescaped/badly formatted message text in some notifications, unreadable message text if the user should be using an OTR addon 
Risk to taking this patch (and alternatives if risky): very low
Attachment #8756935 - Flags: approval-comm-esr45?
Comment on attachment 8756935 [details] [diff] [review]
notification.patch from c1

We would normally want to uplift to intermediate repos as well.
Attachment #8756935 - Flags: approval-comm-beta?
Attachment #8756935 - Flags: approval-comm-aurora?
Attachment #8756935 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 8756935 [details] [diff] [review]
notification.patch from c1

http://hg.mozilla.org/releases/comm-beta/rev/094a5e8c4926
Attachment #8756935 - Flags: approval-comm-beta? → approval-comm-beta+
Comment on attachment 8756935 [details] [diff] [review]
notification.patch from c1

http://hg.mozilla.org/releases/comm-esr45/rev/297a49adcb35
Attachment #8756935 - Flags: approval-comm-esr45? → approval-comm-esr45+
You need to log in before you can comment on or make changes to this bug.