email without headers (Subject, etc) does not display in the inbox

RESOLVED DUPLICATE of bug 1345266

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 1345266
2 years ago
a month ago

People

(Reporter: maurice, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.20 KB, text/plain
Details
(Reporter)

Description

2 years ago
Created attachment 8757613 [details]
spam.eml

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

I received the spam email below in my inbox, the name of the account appeared in blue to indicate that I had unread message.

Here is the spam email (I changed my real email address by *******@*************.com):

Return-Path: <ab@a.kuisf.com>
Delivered-To: *******@*************.com
Received: from smtpin1.paris1.alwaysdata.com ([2a00:b6e0:1:42:1::1])
	(using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits))
	by imap2.paris1.alwaysdata.com (Dovecot) with LMTP id T2LNLbivSFeQRgAAOPslWg
	for <*******@*************.com>; Fri, 27 May 2016 22:38:49 +0200
Return-path: <ab@a.kuisf.com>
Envelope-to: *******@*************.com
Delivery-date: Fri, 27 May 2016 22:38:49 +0200
Received: from [171.35.180.24] (helo=a.kuisf.com)
	by smtpin1.paris1.alwaysdata.com with smtp (Exim 4.84)
	(envelope-from <ab@a.kuisf.com>)
	id 1b6OWq-0000to-Uy
	for *******@*************.com; Fri, 27 May 2016 22:38:45 +0200
X-alwaysdata-Virus-Report: CLEAN
X-alwaysdata-Spam-Score: 18.3
X-alwaysdata-Spam-Report: Content analysis details:   (18.3 points, 5.0 required)
	 pts rule name              description
	---- ---------------------- --------------------------------------------------
	 2.7 RCVD_IN_PSBL           RBL: Received via a relay in PSBL
	                            [171.35.180.24 listed in psbl.surriel.com]
	 1.3 RCVD_IN_BL_SPAMCOP_NET RBL: Received via a relay in bl.spamcop.net
	               [Blocked - see <http://www.spamcop.net/bl.shtml?171.35.180.24>]
	 3.3 RCVD_IN_SBL_CSS        RBL: Received via a relay in Spamhaus SBL-CSS
	                            [171.35.180.24 listed in zen.spamhaus.org]
	 3.3 RCVD_IN_PBL            RBL: Received via a relay in Spamhaus PBL
	 0.1 RCVD_IN_SBL            RBL: Received via a relay in Spamhaus SBL
	 1.4 RCVD_IN_BRBL_LASTEXT   RBL: No description available.
	                            [171.35.180.24 listed in bb.barracudacentral.org]
	-0.0 SPF_HELO_PASS          SPF: HELO matches SPF record
	-0.0 SPF_PASS               SPF: sender matches SPF record
	 1.0 MISSING_HEADERS        Missing To: header
	-0.5 BAYES_05               BODY: Bayes spam probability is 1 to 5%
	                            [score: 0.0390]
	 1.8 MISSING_SUBJECT        Missing Subject: header
	 0.8 RDNS_NONE              Delivered to internal network by a host with no rDNS
	 0.5 MISSING_MID            Missing Message-Id: header
	 1.0 MISSING_FROM           Missing From: header
	 1.4 MISSING_DATE           Missing Date: header

Z.



Actual results:

When clicking in the inbox, I only found already read messages (only 8 email actually) and no trace of unread email.


Expected results:

I should have been able to see what was the new unread message.

Comment 1

2 years ago
Please attach the original messasge to the bug report
Component: Untriaged → Mail Window Front End
Flags: needinfo?(maurice)
(Reporter)

Comment 2

2 years ago
It has been attached already (see spam.eml).

Comment 3

2 years ago
Ah yes. It's missing all the headers. That's odd.  You are correct that the message does not show in the message list.

Equally odd is I don't find any similar bug reports (open,dup,invalid,wontfix) which seems highly improbable. My search foo is off.

rsx11m, aceman does it sound familiar
Component: Mail Window Front End → Folder and Message Lists
Flags: needinfo?(maurice)
Summary: Almost empty spam email does not display in the inbox → email without headers (Subject, etc) does not display in the inbox
Attachment #8757613 - Attachment mime type: message/rfc822 → text/plain

Comment 4

2 years ago
It is a feature that we do not show such malformed junk :)

But I can't reproduce this. I put the eml file into a new folder (manual file manupulation), then started TB. The folder has one message (in the Total column) and it also has a row for the message in the message list. The From is shown as '-', Correspondents is '-', it does have a Date (probably from the "From - " message starter in the mbox file. Also it can be viewed and the only information shown is the "Z." body.

Comment 5

a year ago
Hi all,

got the same issue. I copy my non-displayed email here:

=============================================================
Received: from [171.226.104.181]
	by d3s.mff.cuni.cz with esmtp (Exim 4.86_2)
	(envelope-from <healthforsex@gmail.com>)
	id 1ckpM7-00022K-IT
	for xxx@xxx.xxx; Mon, 06 Mar 2017 10:55:06 +0100
X-Spam-Score: 13.4
X-Spam-Level: +++++++++++++
X-Spam-Flag: YES
X-Spam-Report: Spam detection software, running on the system "xxx.xxx.xxx",
 has identified this incoming email as possible spam.  The original
 message has been attached to this so you can view it or label
 similar future email.  If you have any questions, see
 the administrator of that system for details.
 
 Content preview:  {{BODY_TEXT}} [...] 
 
 Content analysis details:   (13.4 points, 5.0 required)
 
  pts rule name              description
 ---- ---------------------- --------------------------------------------------
  0.4 RCVD_IN_XBL            RBL: Received via a relay in Spamhaus XBL
                             [171.226.104.181 listed in zen.spamhaus.org]
  0.0 RCVD_IN_SORBS_DUL      RBL: SORBS: sent directly from dynamic IP address
                             [171.226.104.181 listed in dnsbl.sorbs.net]
  0.7 SPF_SOFTFAIL           SPF: sender does not match SPF record (softfail)
  1.0 MISSING_HEADERS        Missing To: header
  0.0 FREEMAIL_FROM          Sender email is commonly abused enduser mail provider
                             (healthforsex[at]gmail.com)
  0.8 BAYES_50               BODY: Bayes spam probability is 40 to 60%
                             [score: 0.4730]
  1.4 PYZOR_CHECK            Listed in Pyzor (http://pyzor.sf.net/)
  1.4 MISSING_DATE           Missing Date: header
  1.8 MISSING_SUBJECT        Missing Subject: header
  1.0 MISSING_FROM           Missing From: header
  0.0 TVD_SPACE_RATIO        No description available.
  0.5 MISSING_MID            Missing Message-Id: header
  2.5 TVD_SPACE_RATIO_MINFP  Space ratio
  2.0 BODY_EMPTY             No body text in message

{{BODY_TEXT}}

================================================================

The "feature" has the drawback that you cannot delete nor move the mail and TB notifies an incoming mail, each minute or so (IMAP). I have to login via a webmail (generally anything that can display the message) a delete it manually. I believe the problem lies in parsing the mail - it fails for some reason.

Cheers!
Jan
Gene fixed this in bug 1345266. That should be fixed in TB 52.7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1345266
You need to log in before you can comment on or make changes to this bug.