Closed Bug 1276586 Opened 6 years ago Closed 6 years ago

Package hyphenation dictionaries separately for reftests

Categories

(Firefox for Android Graveyard :: Testing, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1276560

People

(Reporter: sebastian, Assigned: k.krish)

References

Details

See bug 1197716 for reference.

As soon as we do not package hyphenation dictionaries inside the APK some reftests might fail. Like we did with fonts in bug 1197716 we need to make sure that we push the hyphenation dictionaries to the device into a folder where Gecko is looking for them, when running tests.

* Run reftests on try without hyphenation dictionaries. Use MOZ_EXCLUDE_HYPHENATION_DICTIONARIES from bug 1175555. See what tests fail.

* Create patch for pushing the dictionaries to the profile.

* Run reftests again with MOZ_EXCLUDE_HYPHENATION_DICTIONARIES and the patch applied. The tests should pass now again.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1276560
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.