Closed Bug 1276695 Opened 6 years ago Closed 6 years ago

Zooming in/out not working on touchscreen Dell laptop,Ubuntu(14.04) but working with another browser

Categories

(Core :: Panning and Zooming, defect)

46 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1245183

People

(Reporter: meena24dhanani, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160511224433

Steps to reproduce:

I logged onto a website and tried to zoom in using touch on my Dell laptop, having Ubuntu(14.04). I also tried the same using another browser.


Actual results:

Zoom in did not work, instead it started selecting random text on website because of the touch. But the other browser could zoom in easily with touch.
So problem may not lie in Ubuntu or my laptop.


Expected results:

Firefox should have been able to zoom into the content on the website.
To use touch input, you have to set MOZ_USE_XINPUT2=1
ah, SupportsApzTouchInput isn't implemented in GTK3.
Status: UNCONFIRMED → NEW
Component: Untriaged → Panning and Zooming
Ever confirmed: true
Product: Firefox → Core
(In reply to Makoto Kato [:m_kato] from comment #2)
> ah, SupportsApzTouchInput isn't implemented in GTK3.

That's a good point, we should fix that - I'll file another bug for it. However it's unrelated to the actual bug here. Pinch-zoom is not supported on desktop at the moment, we have bug 1245183 on file for that.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: desktop-zoom
You need to log in before you can comment on or make changes to this bug.