Closed Bug 1277515 Opened 5 years ago Closed 5 years ago

Missing localization notes for strings in v5.0

Categories

(Firefox for iOS :: Localization, defect)

Other
iOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fxios-v5.0 --- fixed
fxios-v6.0 --- fixed

People

(Reporter: stef, Assigned: flod)

References

Details

Attachments

(1 file)

48 bytes, text/x-github-pull-request
sleroux
: review+
Details | Review
Thanks for the list of strings, grouping it in a single bug to make it actionable. For the record, I close the other bug because it was missing such a list.

Missing localization note for "Double tap and hold to open history" string
https://github.com/splewako/mozilla-l10n-en/blame/ca4b68235b2fcb48b970869408d30704907e9a86/en.xliff#L53-57

Missing localization note for "Closing tab" string
https://github.com/splewako/mozilla-l10n-en/blame/95c10cded35c40d7bfbcefe4c4ec07a6be2be551/en.xliff#L281-285

Missing localization note for ShortcutItemTitleNewTab ("New Tab") string
https://github.com/splewako/mozilla-l10n-en/blame/b7ae240f0a481ac201dc614e54375fa0ced3941f/en.xliff#L50-53

Missing localization note for NSLocationWhenInUseUsageDescription ("Websites you visit may request your location.") string
https://github.com/splewako/mozilla-l10n-en/blame/243e47d719ffc94d82e822c0966f4cb0de96fe15/en.xliff#L162-165

Missing localization note for ShortcutItemTitleNewPrivateTab ("New Private Tab") string
https://github.com/splewako/mozilla-l10n-en/blame/243e47d719ffc94d82e822c0966f4cb0de96fe15/en.xliff#L158-161

Send Tab, https://github.com/splewako/mozilla-l10n-en/blame/980bc11276d6f8bcf716903a808a79eb865f5977/en.xliff#L875-877
View Later, https://github.com/splewako/mozilla-l10n-en/blame/4fd8eca64865b7e453860a06b55e3a880a32602e/en.xliff#L995-998
Duplicate of this bug: 1277516
Duplicate of this bug: 1277519
Duplicate of this bug: 1277520
Duplicate of this bug: 1277521
Duplicate of this bug: 1277525
Assignee: nobody → francesco.lodolo
Summary: Missing localization note for "Double tap and hold to open history" string → Missing localization notes for strings in v5.0
(In reply to Francesco Lodolo [:flod] from comment #1)
> Missing localization note for "Double tap and hold to open history" string
> https://github.com/splewako/mozilla-l10n-en/blame/
> ca4b68235b2fcb48b970869408d30704907e9a86/en.xliff#L53-57

This string is commented in the source and not available in the exported xliff file, not sure why it's in your export
https://github.com/mozilla/firefox-ios/blob/master/Client/Frontend/Browser/TabToolbar.swift#L88
https://github.com/mozilla-l10n/firefoxios-l10n/blob/master/en-US/firefox-ios.xliff

> Missing localization note for ShortcutItemTitleNewTab ("New Tab") string
> Missing localization note for NSLocationWhenInUseUsageDescription ("Websites
> Missing localization note for ShortcutItemTitleNewPrivateTab ("New Private Tab") string

They all live here, completely different format from the rest of the strings
https://github.com/mozilla/firefox-ios/blob/master/Client/en.lproj/InfoPlist.strings

It seems possible to add comments before a strings as /* comment */, but they're not exported in the XLIFF file. See also
http://stackoverflow.com/questions/32462424/export-localization-missing-strings-in-xliff

Any reason why we're using a .strings file?

> Send Tab,
> View Later,

I'm not sure if it's possible to add comments for these two either, can't even understand for sure from which part of the code they come. Maybe this?
https://github.com/mozilla/firefox-ios/blob/master/Extensions/SendTo/Info.plist#L8

Stephan, do you have any idea about the last two?
Flags: needinfo?(sleroux)
(In reply to Francesco Lodolo [:flod] from comment #7)
> Stephan, do you have any idea about the last two?

Last two = InfoPlist.strings and CFBundleDisplayName strings.
> I'm not sure if it's possible to add comments for these two either, can't even understand for sure from which part of the code they come. Maybe this?
https://github.com/mozilla/firefox-ios/blob/master/Extensions/SendTo/Info.plist#L8

Yup this is where that string is coming from. The same issue about adding comments to the Shortcut strings applies to these as well since they are both InfoPList.string files.
Flags: needinfo?(sleroux)
Attached file Pull request on GitHub
This PR fixes the only comment I can fix.
Attachment #8759232 - Flags: review?(sleroux)
(In reply to Francesco Lodolo [:flod] from comment #7)
> (In reply to Francesco Lodolo [:flod] from comment #1)
> > Missing localization note for "Double tap and hold to open history" string
> > https://github.com/splewako/mozilla-l10n-en/blame/
> > ca4b68235b2fcb48b970869408d30704907e9a86/en.xliff#L53-57
> 
> This string is commented in the source and not available in the exported
> xliff file, not sure why it's in your export

Strange, it does for me routinely on Xcode 7.2.1 (last working xcodebuild export version) and on a fresh clone on different machine with Xcode 7.3.1 on master via partial xcodebuild (line 944) and UI (line 778, no targets in file).

Whats more, I think the comment should be added anyway to be ready when uncommented (and not to file a bug again).
Added comment. 

I'm using 7.3.1 and gtimeout to make the export completes within 15 minutes. The string was definitely not there with 7.3.0, and it also seems very old (1.1).
(In reply to Francesco Lodolo [:flod] from comment #12)
> I'm using 7.3.1 and gtimeout to make the export completes within 15 minutes.
ehm, 15 seconds
Attachment #8759232 - Flags: review?(sleroux) → review+
master 6d24061729ec7ea1f392b71523412e4aa5b78b84
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [needsuplift]
Adding in the bug a summary of the IRC discussion: it's currently not possible to move the strings out of InfoPlist.strings and Info.plist, which also means we can't have comments for those.
v5.x 70ed6ef1aca07711310123ed0f4720d8234f4bf8
Whiteboard: [needsuplift]
You need to log in before you can comment on or make changes to this bug.