If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add crash signature field for "External Software Affecting Firefox" product

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Administration
--
enhancement
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: philipp, Assigned: dylan)

Tracking

({regression})

Production
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
it would be nice to have the ability to attach crash signatures to bugs filed under the "External Software Affecting Firefox" product, since quite a number of these external issues cause us to crash unfortunately.
(Assignee)

Updated

a year ago
Assignee: nobody → dylan
(Assignee)

Comment 1

a year ago
This is a regression from bug 1267785, "Plugins" had the crash sig field enabled.
Depends on: 1267785
Keywords: regression
(Assignee)

Comment 2

a year ago
Created attachment 8759771 [details] [diff] [review]
1277863_2.patch

Added the new product name to $cf_visibile_in_products, and I also added a sanity check for this.

sanity checks take a really long time to run, so I added a switch to only run the sanity checks from hooks...
Attachment #8759771 - Flags: review?(dkl)
(Assignee)

Updated

a year ago
Summary: Add crash signature field for "External Software Affecting FIrefox" product → Add crash signature field for "External Software Affecting Firefox" product
Comment on attachment 8759771 [details] [diff] [review]
1277863_2.patch

Review of attachment 8759771 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl with nits on check in.

::: extensions/BMO/Extension.pm
@@ +966,5 @@
>  }
>  
> +sub sanitycheck_check {
> +    my ($self, $args) = @_;
> +    

whitespace in 3 places

::: sanitycheck.cgi
@@ +387,3 @@
>  Bugzilla::Hook::process('sanitycheck_repair', { status => \&Status });
>  
> +goto hooks if $hooks_only;

nit: add newline

@@ +930,4 @@
>  ###########################################################################
>  # Check hook
>  ###########################################################################
> +hooks:

nit: rename to check_hooks and add newline above and below.
Attachment #8759771 - Flags: review?(dkl) → review+
(In reply to David Lawrence [:dkl] from comment #3)
> Comment on attachment 8759771 [details] [diff] [review]
> 1277863_2.patch
> 
> Review of attachment 8759771 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r=dkl with nits on check in.

Oh and go ahead and remove the missing products (or figure out what they changed to) from Data.pm if you feel like.

dkl
(Assignee)

Comment 5

a year ago
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   20bc492..13161f4  master -> master

up-cased and renamed the labels. I believe all uppercase is conventional.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Duplicate of this bug: 1281812
You need to log in before you can comment on or make changes to this bug.