Closed Bug 127810 Opened 23 years ago Closed 7 years ago

Enable UI for zoom, print, and landscape/postscript on Unix once we can

Categories

(Core :: Print Preview, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
mozilla1.1alpha

People

(Reporter: bzbarsky, Assigned: samir_bugzilla)

References

Details

(Whiteboard: [need info from 119491])

Once the back-end issues with device contexts are worked out, the UI for various
print preview things should get re-enabled.
Depends on: 119491
Depends on: 127699
Shouldn't the Subject read ENABLE?
Summary: Disable UI for zoom, print, and landscape/postscript on Unix once we can → Enable UI for zoom, print, and landscape/postscript on Unix once we can
Bug 119491 is targetted for mozilla1.1 so I will target this bug aggressively
for mozilla1.1 as well.
Target Milestone: --- → mozilla1.1
I filed a new patch for bug 127699 which adds a logic to disable/enable the GUI
based on the "print.whileInPrintPreview" prefs value (see bug 127699 comment
#18).

Therefore the fix for this issue is a simple
|user_pref("print.whileInPrintPreview", true);| in unix.js once bug 119491
("Cleanup global vars in PostScript and Xprint modules") has been fixed.
very inconvenient to print, if not fix.
I escalate it to nsbeta1. 
Keywords: nsbeta1
Nav triage team: need to know when bug 119491 will be fixed.
Whiteboard: [need info from 119491]
*** Bug 175021 has been marked as a duplicate of this bug. ***
Nav triage team: nsbeta1-
Keywords: nsbeta1nsbeta1-
Fixed as part of current work in bug 187125 - PrintPreview's toolbar is now
enabled again if the underlying device code supports multiple device instances
(this is true for the Xprint module, the PostScript module may likely never be
fixed).

Marking bug as FIXED.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED

Louie/Pete, any thoughts with regard to comment 8 ?
See bug 126802, comment 18 -- the same applies here.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
isn't bug 119491 patched?
QA Contact: sujay → printing
Status: REOPENED → RESOLVED
Closed: 22 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.