3,900 instances of "NS_ENSURE_TRUE(editor) failed" emitted from editor/libeditor/nsEditorCommands.cpp during linux64 debug testing

RESOLVED FIXED in Firefox 50

Status

()

Core
Editor
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: erahm, Assigned: mystor)

Tracking

(Blocks: 1 bug, {regression})

Trunk
mozilla50
regression
Points:
---

Firefox Tracking Flags

(firefox50 fixed)

Details

Attachments

(1 attachment)

> 3874 WARNING: NS_ENSURE_TRUE(editor) failed: file editor/libeditor/nsEditorCommands.cpp, line 584

This warning [1] shows up in the following test suites:

>   3612 - [TC] Linux64 web-platform-tests-e10s-5 5
>    119 - [TC] Linux64 mochitest-browser-chrome-e10s-3 bc3
>     49 - [TC] Linux64 mochitest-browser-chrome-e10s-1 bc1
>     28 - [TC] Linux64 firefox-ui-tests functional e10s en-US
>     21 - [TC] Linux64 mochitest-browser-chrome-e10s-4 bc4
>     14 - [TC] Linux64 mochitest-2 2
>      7 - [TC] Linux64 mochitest-browser-chrome-e10s-5 bc5
>      7 - [TC] Linux64 mochitest-plain-e10s-10 10
>      7 - [TC] Linux64 mochitest-plain-e10s-3 3
>      7 - [TC] Linux64 mochitest-3 3
>      2 - [TC] Linux64 mochitest-clipboard cl
>      1 - [TC] Linux64 mochitest-chrome-3 c3

It shows up in 20 tests. A few of the most prevalent:

>   3570 - [e10s] /html/semantics/forms/textfieldselection/selection.html
>    105 - [e10s] dom/tests/browser/browser_focus_steal_from_chrome.js
>     35 - [e10s] /html/semantics/forms/textfieldselection/select-event.html
>     35 - [e10s] browser/base/content/test/urlbar/browser_bug1025195_switchToTabHavingURI_aOpenParams.js
>     21 - [e10s] test_safe_browsing_notification.py TestSafeBrowsingNotificationBar.test_notification_bar
>     14 - [e10s] browser/components/newtab/tests/browser/browser_newtab_overrides.js
>     14 -        dom/browser-element/mochitest/test_browserElement_oop_SetInputMethodActive.html
>      7 - [e10s] browser/components/contextualidentity/test/browser/browser_aboutURLs.js
>      7 - [e10s] dom/tests/browser/browser_autofocus_background.js
>      7 - [e10s] /html/semantics/interactive-elements/the-dialog-element/dialog-showModal.html

[1] https://hg.mozilla.org/mozilla-central/annotate/0a3b6e2df656/editor/libeditor/nsEditorCommands.cpp#l584
This regressed somewhere in here: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a884b96685aa13b65601feddb24e5f85ba861561&tochange=f3f2fa1d7eed5a8262f6401ef18ff8117a3ce43e

My bet is bug 1208217, :mystor what do you think?
Flags: needinfo?(michael)
Keywords: regression

Updated

2 years ago
tracking-e10s: --- → ?

Updated

2 years ago
tracking-e10s: ? → ---
(Assignee)

Comment 2

2 years ago
Firstly, I've looked at the changes for bug 1208217 again, and I'm not sure how it could have caused this increase in warning spam. I'm also not convinced that this warning is super legitimate as an actual failure case (it was changed from a if (!editor) return NS_OK; by a regular expression in bug 572618), and the warning itself should probably be removed. 

I'm going to check with ehsan to make sure that my assumptions are correct.
Flags: needinfo?(michael) → needinfo?(ehsan)

Comment 3

2 years ago
We should remove this warning.  r+ on a patch that does that.  :-)
Flags: needinfo?(ehsan)
(Assignee)

Comment 4

2 years ago
Created attachment 8760959 [details] [diff] [review]
Disable warning in nsDeleteCommand::IsCommandEnabled
(Assignee)

Updated

2 years ago
Assignee: nobody → michael

Comment 5

2 years ago
Pushed by michael@thelayzells.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b764ee0f465e
Disable warning in nsDeleteCommand::IsCommandEnabled, r=ehsan
Alright I got my bisector working again, for posterity it looks like it was actually this push that regressed: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=83e8b01535bf1b574338859b8e26e2f1a86030e0&tochange=ea96f5a5d0b523b19627b1b98e25a28e956890dc

Appears to be updating tests.

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b764ee0f465e
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.