Memory leak of 256 bytes from 1 block allocated in PL_DHashAllocTable

VERIFIED DUPLICATE of bug 129635

Status

()

Core
XPCOM
--
major
VERIFIED DUPLICATE of bug 129635
17 years ago
16 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: Mitchell Stoltz (not reading bugmail))

Tracking

({memory-leak})

Trunk
x86
Windows 2000
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Build ID: Current (1:45 pm - 2-26-2002) Windows 2000 trunk build under Purify.

Summary: Memory leak of 256 bytes from 1 block allocated in PL_DHashAllocTable

Steps to Reproduce:

1. Launch Mozilla under Purify with http://www.mozilla.org set as your homepage.

[W] MLK: Memory leak of 256 bytes from 1 block allocated in PL_DHashAllocTable
        Distribution of leaked blocks
               256 bytes from 1 block of 256 bytes (0x04aaa750) 
        Allocation location
            malloc         [MSVCRT.DLL]
            PL_DHashAllocTable [pldhash.c:62]
                
                PR_IMPLEMENT(void *)
                PL_DHashAllocTable(PLDHashTable *table, PRUint32 nbytes)
             => {
                    return malloc(nbytes);
                }
                
            PL_DHashTableInit [pldhash.c:202]
                    table->generation = 0;
                    nbytes = capacity * entrySize;
                
             =>     table->entryStore = ops->allocTable(table, nbytes);
                    if (!table->entryStore)
                        return PR_FALSE;
                    memset(table->entryStore, 0, nbytes);
            InitClassPolicyEntry [nsScriptSecurityManager.h:207]
            ???            [ip=0x044d2958]
            PL_DHashTableOperate [pldhash.c:533]
                                keyHash |= COLLISION_FLAG;
                            }
                            if (table->ops->initEntry)
             =>                 table->ops->initEntry(table, entry, key);
                            entry->keyHash = keyHash;
                            table->entryCount++;
                        }
            nsScriptSecurityManager::InitDomainPolicy(JSContext *,char
const*,DomainPolicy *) [nsScriptSecurityManager.cpp:2492]
                          NS_REINTERPRET_CAST(ClassPolicy*,
                                              PL_DHashTableOperate(aDomainPolicy,
                                                                   start,
             =>                                                    PL_DHASH_ADD));
                
                        if (!cpolicy)
                            break;
            nsScriptSecurityManager::InitPolicies(void)
[nsScriptSecurityManager.cpp:2309]
            nsScriptSecurityManager::Observe(nsISupports *,char const*,WORD
const*) [nsScriptSecurityManager.cpp:2147]
            nsObserverService::NotifyObservers(nsISupports *,char const*,WORD
const*) [nsObserverService.cpp:211]
            nsProfile::SetCurrentProfile(WORD const*) [nsProfile.cpp:1193]
            nsProfile::LoadDefaultProfileDir(nsCString&,int) [nsProfile.cpp:588]
            nsProfile::StartupWithArgs(nsICmdLineService *,int) [nsProfile.cpp:418]
            nsAppShellService::DoProfileStartup(nsICmdLineService *,int)
[nsAppShellService.cpp:243]
            InitializeProfileService [nsAppRunner.cpp:936]
            main1          [nsAppRunner.cpp:1238]
            main           [nsAppRunner.cpp:1625]
            WinMain        [nsAppRunner.cpp:1643]
            WinMainCRTStartup [crtexew.obj]
Severity: critical → major
Keywords: mlk

Comment 1

17 years ago
to neeti.
Assignee: dougt → neeti

Comment 2

17 years ago
nsScriptSecurityManager.cpp is calling PL_DHashTableOperate(....)
Assignee: neeti → mstoltz

*** This bug has been marked as a duplicate of 129635 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.