Closed Bug 1279708 Opened 3 years ago Closed 3 years ago

highlight is wrong if scrolled

Categories

(Toolkit :: Find Toolbar, defect)

50 Branch
defect
Not set
Points:
1

Tracking

()

VERIFIED FIXED
mozilla51
Iteration:
51.3 - Sep 19
Tracking Status
firefox50 --- disabled
firefox51 + disabled
firefox52 --- verified

People

(Reporter: alice0775, Assigned: mikedeboer)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached file bug.html
Steps to reproduce:
1. open attached
2. Ctrl+f, type bla
3. Hit ENTER and repeat Step.3
No longer blocks: 384458
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1279695
[Tracking Requested - why for this release]:

I can still reproduce on Nightly51.0a1

https://hg.mozilla.org/mozilla-central/rev/7e873393cc11d326338779e5a3ed2da031e30936
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 ID:20160911030419
Blocks: 384458, 1291278
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This is probably a duplicate of bug 1279695.
(In reply to Marco Castelluccio [:marco] from comment #3)
> This is probably a duplicate of bug 1279695.

No this is a different bug, in that we don't recalculate the geometry of ranges when we scrollIntoView the current found range.
Assignee: nobody → mdeboer
Status: REOPENED → ASSIGNED
Iteration: --- → 51.3 - Sep 19
Points: --- → 1
Flags: qe-verify+
Flags: firefox-backlog+
Comment on attachment 8791624 [details]
Bug 1279708 - update the geometry of all ranges upon the next dimmed mask repaint in the case of a 'findAgain' update, because the page may have scrolled.

https://reviewboard.mozilla.org/r/78998/#review77616

Should this have a test for it?
Attachment #8791624 - Flags: review?(jaws) → review+
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #6)
> Should this have a test for it?

I'll work on a test asap, in another bug.
https://hg.mozilla.org/integration/fx-team/rev/4b1afa9d2e99ff11f590c253e33f65ec49157ea8
Bug 1279708 - update the geometry of all ranges upon the next dimmed mask repaint in the case of a 'findAgain' update, because the page may have scrolled. r=jaws
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/945d91bffbdd
update the geometry of all ranges upon the next dimmed mask repaint in the case of a 'findAgain' update, because the page may have scrolled. r=jaws
Blocks: 1279695
https://hg.mozilla.org/integration/fx-team/rev/6ac553163f6b9f2f5565fe09b8afdffa0d820984
Backed out changeset 4b1afa9d2e99 (bug 1279708), because it landed on autoland earlier. r=backout DONTBUILD
https://hg.mozilla.org/mozilla-central/rev/945d91bffbdd
Status: ASSIGNED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
QA Contact: brindusa.tot
I've reproduced the initial issue on Nightly 50.0a1 (Build ID: 20160611030214) on Windows 10. 

Verified fixed (when following the STR from the description) using Nightly 52 (Build ID: 20160919065232) on Windows 10, Ubuntu 16.04 and Mac OS X 10.11. 

But, the issue is still reproducible if scrolling is done via mouse. Please see the attached screen-cast.

Mike, will the above issue be covered by Bug 1279695? Please let me know if I should log a new bug to cover the scrolling via mouse issue.
Flags: needinfo?(mdeboer)
(In reply to Simona B [:simonab ] from comment #13)
> Mike, will the above issue be covered by Bug 1279695? Please let me know if
> I should log a new bug to cover the scrolling via mouse issue.

This is covered by bug 1302534.
Flags: needinfo?(mdeboer)
Based on Comment 15, setting the status of this issue to Verified Fixed. 

I'm also removing the qa-verify flag since this Feature is disabled by default on Firefox 51.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Based on previous comment

> I'm also removing the qa-verify flag since this Feature is disabled by
> default on Firefox 51.

update status-firefox51 to Disabled.
You need to log in before you can comment on or make changes to this bug.