pressing <ENTER> on Bugzilla query page should submit query

VERIFIED DUPLICATE of bug 28763

Status

()

Core
HTML: Form Submission
VERIFIED DUPLICATE of bug 28763
17 years ago
17 years ago

People

(Reporter: Michael Wardle, Assigned: John Keiser (jkeiser))

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
build 2002022603

Sometimes when I go to the Mozilla bugs search page, select a few options, then
click "submit query", I am returned to the query page, rather than moved on to
the "please wait" page, then the bug list.

It seems to happen most when I click things quickly, and I suspect that the
query page is still loading when I click the submit button.

If I wanted to reproduce it, I'd try selecting a few STATUSes, selecting a
PRODUCT, then quickly clicking submit query before the COMPONENT box could
update with the relevant COMPONENTs for the PRODUCT.

This has been happening on several previous builds.

Not sure what the most relevant component is; probably something like
Gecko/Necko/core rendering or form submission.

Comment 1

17 years ago
I've seen this too, confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 2

17 years ago
john do you mind if i reassign this to you?
Assignee: alexsavulov → jkeiser
(Assignee)

Comment 3

17 years ago
What do you mean you've seen it on previous builds (previous nightlies)?  What
platform is this?  (I haven't been seeing it at all on Linux 2002022508, and I
do a lot of queries.)

As to reproducing: I am entirely unable to click the Submit Query button fast
enough to beat the COMPONENT box update.  (I even went so far as to hover the
mouse over Submit Query, use the keyboard to select the product, and immediately
click Submit Query afterwards.)  Is that definitely the step to reproduce?

Comment 4

17 years ago
I've seen this a few times on Win 98 (using 2002022503 right now). I think it
started maybe a week ago.
Can't reproduce it though...
(Reporter)

Comment 5

17 years ago
John: I've been seeing this for a long time, including many previous
releases/milestone builds, so I assume it's always been present.

I can't always reproduce this, but it does seem to happen most when I fill in
several fields then quickly press the submit button.  I hadn't bothered to
submit it until now because I couldn't reliably reproduce it, but I think it's
important that this sort of behavior is fixed by Moz 1.0 if we can find out why
it's happening.

The fields I normally use are:
- status
- product
- search summary
- component

and I'd try a product such as browser or mailnews, and they seem to have fairly
long component lists.

Sorry I can't provide definite instructions.
(Assignee)

Comment 6

17 years ago
Bugs I can't reproduce but might be reproducible -> Future
Target Milestone: --- → Future
(Reporter)

Comment 7

17 years ago
I'm seeing this every time on 0.9.9 (2002031104) on Win2000.  This is what I'm
doing:

1) go to the Bugzilla query page <URL:http://bugzilla.mozilla.org/query.cgi#chart>
2) select all STATUSes
3) select one PROGRAM (e.g. MailNews)
4) enter a two-word Summary (e.g. proxy auto)
5) press <ENTER>

Maybe it happens when pressing <ENTER>, I'm not sure.

It happens lots, and is quite annoying.  Severity -> Normal.
Severity: minor → normal
(Reporter)

Comment 8

17 years ago
It's definately happening when pressing ENTER on the keyboard rather than
clicking the Submit button.  I tried several different fields, and not matter
what I did, pressing ENTER caused the page to reload.

Changing summary to something more appropriate.

Summary: clicking search in Bugzilla sometimes bring me back to the query page → pressing <ENTER> on Bugzilla query page should submit query

Comment 9

17 years ago
I believe this is fixed on the bugzilla tip, so b.m.o will be fixed time next 
time it updates.

*** This bug has been marked as a duplicate of 28763 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.