Query page, location of submit button

RESOLVED FIXED in Bugzilla 2.16

Status

()

P2
normal
RESOLVED FIXED
19 years ago
6 years ago

People

(Reporter: jruderman, Assigned: endico)

Tracking

2.13
Bugzilla 2.16
x86
Windows 98

Details

(URL)

(Reporter)

Description

19 years ago
The submit button isn't the first button on the form ("or" is), so MSIE tries 
to submit using "or" instead of "submit query". The user ends up back at the 
query page, and after about 10 seconds, notices that his query is actually 
still there but that the results aren't. He thinks his query returned no 
results..

Anyway, suggested solution: add another "submit query" button above the boolean 
chart stuff, and put a "or scroll down for more" to the right of that button.
(Reporter)

Comment 1

19 years ago
*** Bug 28765 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
This bug has not been touched for more than nine months. In most cases, that 
means it has "slipped through the net". Please could the owner take a moment to 
add a comment to the bug with current status, and/or close it.

Thank you :-)

Gerv
QA Contact: matty
Whiteboard: 2.14

Comment 4

18 years ago
*** Bug 68741 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
From bug 68741:

I always have to scroll down to submit my queries, and that submit query button 
is hidden between two other big buttons.  We should add another submit query (you 
can have more than one! really!) button at the top to make doing queries faster 
and easier to discover...

Updated

18 years ago
Depends on: 16775

Updated

18 years ago
Whiteboard: 2.14 → 2.16
moving to real milestones...
Target Milestone: --- → Bugzilla 2.16
Apparently this is or will shortly be a Mozilla issue too so I'll raise priority
to P2.
Priority: P3 → P2
Whiteboard: 2.16
Mass moving to new product Bugzilla...
Assignee: tara → endico
Component: Bugzilla → Query/Bug List
Product: Webtools → Bugzilla
Version: other → 2.13
There will be 2 submit buttons in the rewritten query.cgi. I believe one of them
will be the first button on the page.

Gerv
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
Should be fixed during 2.16 ...
Target Milestone: Bugzilla 2.18 → Bugzilla 2.16
This has been fixed by the query redesign on the above bug number.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
*** Bug 110896 has been marked as a duplicate of this bug. ***
Depends on: 98707
No longer depends on: 16775
(Reporter)

Comment 15

17 years ago
*** Bug 128014 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
This is still occuring
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 17

17 years ago
*** Bug 104211 has been marked as a duplicate of this bug. ***
Vladimir: where?

On bugzilla.mozilla.org?  If so, that's because b.m.o hasn't updated since this
was fixed.  This is fixed on the tip unless you can reproduce it at
http://landfill.bugzilla.org/bugzilla-tip/query.cgi  (in which case, reopen this
again and say that's where you reproduced it)
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 19

17 years ago
*** Bug 148560 has been marked as a duplicate of this bug. ***

Comment 20

17 years ago
*** Bug 151219 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
*** Bug 151219 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
b.m.o was updated yesterday and I still dont see any change. I cannot submit
with enter. It starts Adding a field to the query page...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Thats because bmo is using the old query field, still - try
http://bugzilla.mozilla.org/quer.cgi?format=modern
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.