Warning issued when using prefixed Fullscreen API, but unprefixed API is not available

RESOLVED FIXED in Firefox 48

Status

()

defect
RESOLVED FIXED
3 years ago
2 months ago

People

(Reporter: tomerlahav, Assigned: emk)

Tracking

47 Branch
mozilla50
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 fixed, firefox49 fixed, firefox50 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

See simple repro example here:
https://s3.amazonaws.com/storage2.interlude.fm/dev_temp/tomer/firefox_fullscreen_bug/ff_fullscreen.html


Actual results:

Using the prefixed Fullscreen API causes a warning to be issued:
"Prefixed Fullscreen API is deprecated."

However, there's no unprefixed API available.


Expected results:

Either unprefixed API should be made available, or no warning should be displayed.

Comment 1

3 years ago
The API is disabled by default, See Bug 1268749

If you want to use the API, set full-screen-api.unprefix.enabled to true in about:config.
Component: Untriaged → DOM
Product: Firefox → Core

Updated

3 years ago
Blocks: 1268749
Assignee

Comment 2

3 years ago
(In reply to Alice0775 White from comment #1)
> The API is disabled by default, See Bug 1268749
> 
> If you want to use the API, set full-screen-api.unprefix.enabled to true in
> about:config.

Obviously site authors can't force users to flip the pref. We should suppress the warning if the pref is false.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Comment 3

3 years ago
Looks like the WebIDL [Deprecated] annotation cannot be conditional :(
Assignee

Comment 5

3 years ago
I intentionally left string changes to make uplift easier.
Comment on attachment 8766743 [details]
Bug 1280545 - Remove [Deprecated="PrefixedFullscreenAPI"] annotations until we are ready to unprefix fullscreen API.

https://reviewboard.mozilla.org/r/61526/#review58368

Hmmm... okay...
Attachment #8766743 - Flags: review?(xidorn+moz) → review+

Comment 7

3 years ago
Pushed by VYV03354@nifty.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/bedd6091246e
Remove [Deprecated="PrefixedFullscreenAPI"] annotations until we are ready to unprefix fullscreen API. r=xidorn
Comment on attachment 8766743 [details]
Bug 1280545 - Remove [Deprecated="PrefixedFullscreenAPI"] annotations until we are ready to unprefix fullscreen API.

This one touches WebIDL and needs a DOM peer to review. (Though this isn't really a change to any API...)
Attachment #8766743 - Flags: review+ → review?(bugs)
sorry had to back this out since this was running into the hook that prevent webidl changes without dom peer reviews. Seems mozreview/autoland did not noticed this and i filed bug 1283798 for this

Comment 10

3 years ago
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0f7988afce2c
Backed out changeset bedd6091246e run into hg hook warning for webidl and backout for making autoland to m-c merge possible
Comment on attachment 8766743 [details]
Bug 1280545 - Remove [Deprecated="PrefixedFullscreenAPI"] annotations until we are ready to unprefix fullscreen API.

https://reviewboard.mozilla.org/r/61526/#review58632
Attachment #8766743 - Flags: review?(bugs) → review+

Comment 12

3 years ago
Pushed by VYV03354@nifty.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/3ac069d1e022
Remove [Deprecated="PrefixedFullscreenAPI"] annotations until we are ready to unprefix fullscreen API. r=smaug,xidorn

Comment 13

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3ac069d1e022
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Assignee

Comment 14

3 years ago
Comment on attachment 8766743 [details]
Bug 1280545 - Remove [Deprecated="PrefixedFullscreenAPI"] annotations until we are ready to unprefix fullscreen API.

Approval Request Comment
[Feature/regressing bug #]: 1268749
[User impact if declined]: Some advanced users and web authors will be confused by console messages.
[Describe test coverage new/current, TreeHerder]: Manually tested
[Risks and why]: Very low, only removes an auto-generated warning message.
[String/UUID change made/needed]: none. strings are left intact.
Attachment #8766743 - Flags: approval-mozilla-beta?
Attachment #8766743 - Flags: approval-mozilla-aurora?
Comment on attachment 8766743 [details]
Bug 1280545 - Remove [Deprecated="PrefixedFullscreenAPI"] annotations until we are ready to unprefix fullscreen API.

This patch removes an auto-generated warning message. Take it in 48 beta 6 and aurora.
Attachment #8766743 - Flags: approval-mozilla-beta?
Attachment #8766743 - Flags: approval-mozilla-beta+
Attachment #8766743 - Flags: approval-mozilla-aurora?
Attachment #8766743 - Flags: approval-mozilla-aurora+
has problems applying to beta:

grafting 352707:3534349c6d78 "Bug 1280545 - Remove [Deprecated="PrefixedFullscreenAPI"] annotations until we are ready to unprefix fullscreen API. r=smaug r=xidorn, a=gchang"
merging dom/webidl/Document.webidl
warning: conflicts while merging dom/webidl/Document.webidl! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use 'hg resolve' and 'hg graft --continue')
Flags: needinfo?(VYV03354)
Assignee

Comment 18

3 years ago
Flags: needinfo?(VYV03354)

Updated

3 years ago
Duplicate of this bug: 1286720
Duplicate of this bug: 1286920
Assignee: nobody → VYV03354
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.