Android native fling animation is returning an inverted velocity

VERIFIED FIXED in Firefox 48

Status

()

Firefox for Android
Toolbar
P2
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: rbarker, Assigned: rbarker)

Tracking

({regression})

48 Branch
Firefox 50
regression
Points:
---

Firefox Tracking Flags

(firefox47 unaffected, firefox48 verified, firefox49 verified, firefox50 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
The android native fling animation is returning the velocity inverted. This is causing permanent checkerboarding in some situations.
(Assignee)

Comment 1

2 years ago
Created attachment 8763193 [details] [diff] [review]
0001-Bug-1280580-Android-native-fling-animation-is-returning-an-inverted-velocity-r-16061710-ff50a23.patch
Attachment #8763193 - Flags: review?(bugmail.mozilla)
Comment on attachment 8763193 [details] [diff] [review]
0001-Bug-1280580-Android-native-fling-animation-is-returning-an-inverted-velocity-r-16061710-ff50a23.patch

Review of attachment 8763193 [details] [diff] [review]:
-----------------------------------------------------------------

Check to see if this fixes bug 1280085 too.
Attachment #8763193 - Flags: review?(bugmail.mozilla) → review+
Assignee: nobody → rbarker
Priority: -- → P2

Comment 3

2 years ago
Pushed by rbarker@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f97c058ecdeb
Android native fling animation is returning an inverted velocity r=kats
Blocks: 1276463
status-firefox49: --- → unaffected
status-firefox50: --- → affected
Duplicate of this bug: 1280085
Keywords: regression

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f97c058ecdeb
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
(Assignee)

Comment 6

2 years ago
Comment on attachment 8763193 [details] [diff] [review]
0001-Bug-1280580-Android-native-fling-animation-is-returning-an-inverted-velocity-r-16061710-ff50a23.patch

Approval Request Comment
[Feature/regressing bug #]: End of page bounce animation plays at the wrong end of the page.
[User impact if declined]: Application will give incorrect user feedback when end of page is reached.
[Describe test coverage new/current, TreeHerder]: None, just manually verified.
[Risks and why]: Very low risk. Patch only negates the calculated velocity.
[String/UUID change made/needed]: none.
Attachment #8763193 - Flags: approval-mozilla-beta?
Attachment #8763193 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

2 years ago
No longer blocks: 1276463
Depends on: 1276463

Updated

2 years ago
status-firefox48: --- → affected
status-firefox49: unaffected → affected
Comment on attachment 8763193 [details] [diff] [review]
0001-Bug-1280580-Android-native-fling-animation-is-returning-an-inverted-velocity-r-16061710-ff50a23.patch

Review of attachment 8763193 [details] [diff] [review]:
-----------------------------------------------------------------

Fix a regression. Take it in 48 beta 4 and aurora.
Attachment #8763193 - Flags: approval-mozilla-beta?
Attachment #8763193 - Flags: approval-mozilla-beta+
Attachment #8763193 - Flags: approval-mozilla-aurora?
Attachment #8763193 - Flags: approval-mozilla-aurora+

Comment 8

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/fb650a44de9e
status-firefox49: affected → fixed
has problems uplifting to beta 

merging gfx/layers/apz/src/AndroidAPZ.cpp
warning: conflicts while merging gfx/layers/apz/src/AndroidAPZ.cpp! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
Flags: needinfo?(rbarker)
worked after landing the other patch 

https://hg.mozilla.org/releases/mozilla-beta/rev/f63502a8a7ea
status-firefox48: affected → fixed
Flags: needinfo?(rbarker)
Verified as fixed in build Firefox 48 Beta 6;
Device: LG G4 (Android 5.1).
status-firefox48: fixed → verified
status-firefox47: --- → unaffected
Version: unspecified → 48 Branch
Verified as fixed in build Firefox 50.0a1 (2016-07-12);
Device: Prestigio Grace X5 (Android 4.4.2).
status-firefox50: fixed → verified
Verified as fixed in build Firefox 49.0a2 (2016-07-17);
Device: LG G4 (Android 5.1).
status-firefox49: fixed → verified

Comment 14

2 years ago
I'm changing the status to verified fixed considering that the bug is verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.