Closed Bug 1280825 Opened 6 years ago Closed 6 years ago

Download panel is truncated in French when running more than 3 downloads

Categories

(Firefox :: Downloads Panel, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 50
Tracking Status
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- fixed

People

(Reporter: tchevalier, Assigned: adw)

References

Details

(Keywords: nightly-community, regression, Whiteboard: [fxprivacy])

Attachments

(4 files)

Attached image Nightly French
The downloads panel is now truncated in French when more than 3 downloads are running. Cancel buttons are not visible anymore (see attached screenshots)

+ On Mac OS, the "Remaining time" string is now truncated (even with a single download)

It was working with 2016-06-11, it’s broken with 2016-06-15. Unfortunately I can’t use Mozregression since I can only reproduce with localized builds. More locales might be affected.

STR:

- Run 4 downloads at the same time
- Open Download panel from the toolbar
Whiteboard: [fxprivacy][triage]
The date range in comment 0 likely points to bug 1252509.
Blocks: 1252509
Assignee: nobody → adw
Status: NEW → ASSIGNED
Priority: -- → P2
Whiteboard: [fxprivacy][triage] → [fxprivacy]
This part fixes the truncation problem shown in comment 0:

> +/* Make the panel wide enough to show the download list items without improperly
> +   truncating them. */
> +#downloadsPanel-multiView > .panel-viewcontainer,
> +#downloadsPanel-multiView > .panel-viewcontainer > .panel-viewstack,
> +#downloadsPanel-multiView > .panel-viewcontainer > .panel-viewstack > .panel-mainview {
> +  overflow: visible;
> +  max-width: unset;
> +}
> +

The translateX(101%) changes are necessary to prevent a sliver of the left edge of the blocked subview panel from appearing at the right edge of the main view when the subview isn't shown.

I don't understand why the #downloadsSummaryChildBox -moz-margin-end change is necessary, but without it, the #downloadsSummary box doesn't actually get any padding on its right side even though it's there in the CSS, which means that the progress bar in the summary box nearly touches the right edge of the panel.

I also don't understand why the .downloadStackIcon -> .downloadTypeIcon change is necessary, but without it the down-arrow image in the summary box is too big, like the size specified in the CSS isn't getting applied at all.

Review commit: https://reviewboard.mozilla.org/r/60926/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/60926/
Attachment #8765669 - Flags: review?(paolo.mozmail)
(I'd ask Jared for review since he reviewed the original patch, but he's not accepting requests right now.)
Comment on attachment 8765669 [details]
Bug 1280825 - Download panel is truncated in French when running more than 3 downloads.

Jared would be a better reviewer, having worked on the original patch, and I won't be able to get to this review until he's back anyways.
Attachment #8765669 - Flags: review?(paolo.mozmail)
Attachment #8765669 - Flags: review?(jaws)
Version: unspecified → Trunk
Comment on attachment 8765669 [details]
Bug 1280825 - Download panel is truncated in French when running more than 3 downloads.

https://reviewboard.mozilla.org/r/60926/#review60192

::: browser/themes/shared/downloads/downloads.inc.css:41
(Diff revision 1)
> +   /* This value should match the right-side padding of #downloadsSummary. */
> +  -moz-margin-end: 38px;

Can you pull 38px out to a CSS variable?
Attachment #8765669 - Flags: review?(jaws) → review+
https://hg.mozilla.org/integration/fx-team/rev/e2ddf53209916302a81ca331f88b4df8df0ca7c7
Bug 1280825 - Download panel is truncated in French when running more than 3 downloads. r=jaws
https://hg.mozilla.org/mozilla-central/rev/e2ddf5320991
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Depends on: 1288730
Depends on: 1287384
You need to log in before you can comment on or make changes to this bug.