3.17% all platforms session restore no auto restore slope creep on uplift of Firefox 49 to Aurora

RESOLVED WONTFIX

Status

Testing
Talos
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

({perf, regression})

49 Branch
perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_regression][slope_creep])

time to track slope creep, in this case the session_restore_no_auto_restore rose slowly over the last 6 weeks resulting in a 3.17% regression.  I had seen this a few weeks ago and wasn't able to pinpoint anything as the root cause.

https://treeherder.mozilla.org/perf.html#/graphs?timerange=31536000&series=%5Bmozilla-aurora,65c29db3641a56f472ec12cc0631287b6b772299,1,1%5D&series=%5Bmozilla-inbound,65c29db3641a56f472ec12cc0631287b6b772299,1,1%5D&zoom=1457281938642.7385,1465874406013.477,585.6891272071682,731.4167981901563

^ this is a zoom in since March 7th (when Firefox 47 went to aurora, then on April 25th, Firefox 48, then on June 6th, Firefox 49).

You can see over the last 2 release cycles, this specific test has increased >11%.


In fact, this is not restricted to just windows8 (as the above graph shows), this is the case for all platforms:
https://treeherder.mozilla.org/perf.html#/graphs?timerange=31536000&series=%5Bmozilla-inbound,65c29db3641a56f472ec12cc0631287b6b772299,1,1%5D&series=%5Bmozilla-inbound,5ce8015fd602be0464f7c71f806922306a437dbe,1,1%5D&series=%5Bmozilla-inbound,df9bd6774a4f6972adf785df953af8d17ddeb07b,1,1%5D&series=%5Bmozilla-inbound,6aa2e842b18b88cd8a4ac539fd044d06c5871769,1,1%5D&zoom=1457281938642.7385,1465874406013.477,585.6891272071682,731.4167981901563


all above graphs are for e10s, this is a pattern on non e10s as well:
https://treeherder.mozilla.org/perf.html#/graphs?timerange=31536000&series=%5Bmozilla-inbound,5a492103b8e946b10c5cc765b90987ec7297dd14,1,1%5D&series=%5Bmozilla-inbound,59264363c0bbf0ed27c458e0189421c16a25ba3a,1,1%5D&series=%5Bmozilla-inbound,fd2495f0bea3ea8c8b71bc7b5f07a026133d1dda,1,1%5D&series=%5Bmozilla-inbound,1d25612d43b3db9508110a0d2a66476c4b11f6a6,1,1%5D&series=%5Bmozilla-inbound,85410d82800e9bf1ae2b74e2d854362b9dc8dc26,1,1%5D&series=%5Bmozilla-inbound,c84d030ac90b7eb17c4d13120dfaf673e06f6fda,1,1%5D&zoom=1457281938642.7385,1465874406013.477,585.6891272071682,731.4167981901563
we have shipped this and didn't see this in v.50.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.