Closed Bug 1281200 Opened 5 years ago Closed 2 years ago

New show_bug.cgi view should have an option to have fields editable by default.

Categories

(bugzilla.mozilla.org :: User Interface, enhancement)

Production
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: pascalc, Assigned: kohei.yoshino)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review
1/ go to your bugzilla preferences
2/ activate "Use experimental user interface"

Expected result:
Fields should be editable in bugs we visit without clicking on the "edit" button

Actual result:
You have to click on edit for all the bugs you want to edit.

The default behaviour is not helpful to release managers and triagers because a significant part of our work involves updating flags and keywords in  bugs, that means that the first thing we do when we get into a bug is click on a button to actually have access to these fields.

I don't know if the current behaviour is really useful to a lot of people, but if it is then having a preference to have the fields editable by default would be fine.
We've had a lot of positive feedback around the new design; however, I agree that it isn't useful in all cases.  We've been talking about having different views into a bug that would change the UI, e.g. a view for triagers that would have more things editable by default.  We can certainly discuss a general case that would hopefully meet your needs.
(In reply to Mark Côté [:mcote] from comment #1)
> We've had a lot of positive feedback around the new design; however, I agree
> that it isn't useful in all cases.  We've been talking about having
> different views into a bug that would change the UI, e.g. a view for
> triagers that would have more things editable by default.  We can certainly
> discuss a general case that would hopefully meet your needs.

Also, part of the design was to not make everything automatically editable as the readonly page would load faster when we didnt have to populate all of the drop downs and some other form elements on page load. Common operations such as commenting, changing status, etc. would however still work. When clicking "Edit" the form fetches all of the form values and displays them such as product, component which can have many choices. We would need to figure out how to still have fast page load time and have all of the editable fields already populated so they are visible when the user first loads the page. We have talked about maybe caching the values in localStorage and checking periodically if the cache needs to be updated. If this is implemented, we could then add an option to always have the page load in "edit" mode initially as the values are there.

dkl
Component: Bug Creation/Editing → User Interface: Modal
Blocks: 1533096
No longer blocks: 1533096
Blocks: 1273046
Duplicate of this bug: 1541274
Attached file GitHub Pull Request
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Type: defect → enhancement

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Component: User Interface: Modal → User Interface
You need to log in before you can comment on or make changes to this bug.