Closed Bug 1273046 Opened 4 years ago Closed 1 year ago

Disable the legacy non-modal bug UI

Categories

(bugzilla.mozilla.org :: User Interface, task)

Production
task
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: glob, Assigned: kohei.yoshino)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review
keeping the old UI around once the dust has settled from switching bug-modal to the default view means more work in maintaining two separate user interfaces.

after $some_period_of_time the old view should be removed from the bmo codebase (perhaps at the same time as bug 1272773).
No longer depends on: 1150541
Duplicate of this bug: 1533096
Depends on: 1281200, 1345750

The removal may happen in Bug 1272773. We need to disable it first.

Blocks: 1272773
No longer depends on: 1272773
Summary: remove the old bugzilla UI → Disable the legacy non-modal bug UI
Depends on: 1344427
Blocks: bugzilla-6
Depends on: 1344091
Type: defect → task
See Also: → 1546539
Depends on: 1546539
See Also: 1546539
Depends on: 1556531
No longer depends on: 1556531
Depends on: 1556543
Depends on: 1556882
Depends on: 1556884
No longer depends on: 1556882
Depends on: 1558096
No longer depends on: 1371148
No longer depends on: 1248611
Depends on: 1317224
No longer depends on: 1344091

We are almost there. Let’s do this once the a11y issues are solved.

Assignee: nobody → kohei.yoshino

Okay, I'll send an [Intent to Change] email to fx-team, dev-planning, firefox-dev, and tools-bugzilla this week.

Sounds good!

Status: NEW → ASSIGNED
Attached file GitHub Pull Request

This PR just removes the setting and uses the modal UI for everyone.

Bug 1524174 and Bug 1524175 also include a part of removal.

Depends on: 1524174, 1524175

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.