Disable the modal highlight feature on Nightly for now

VERIFIED FIXED in Firefox 50

Status

()

defect
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: mikedeboer, Assigned: mikedeboer)

Tracking

50 Branch
mozilla50
Points:
1
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox49 unaffected, firefox50 verified, firefox51 verified, firefox52 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

See summary.
Flags: qe-verify+
Flags: firefox-backlog+
I don't think we need to disable this on Nightly, FWIW. I was just suggesting on IRC that we should ifdef the pref to NIGHTLY_BUILD so it doesn't ride the trains on the next uplift to Aurora.

But I'll obviously defer to yours and Jared's opinion if you feel it should be fully disabled.
I'm in favor of disabling for now. We've gotten sufficient feedback that we need to either re-approach the problem or fix a large number of issues before it will become usable for many of the power users on Nightly. 

At this point, I think users may be less likely to file bugs under the assumption that their issue is already known and we may start getting less value from keeping it enabled.
Assignee: mdeboer → jaws
Well, I think the problem is not so much disabling the feature (which I think includes enabling highlight all by default), but the unit tests in toolkit/modules/tests/browser/ that assume this pref to be true at the start.
I'd like to disable those and confirm everything works ok with a try push. I can do that tomorrow as well - today was a bit on the busy side. What do you think?
Yeah that's fine. I think it would be better if you take this bug over then :)
Oh, I think your patch is actually almost there :P I was more thorough than I thought!
Steal!
Assignee: jaws → mdeboer
Attachment #8764648 - Attachment is obsolete: true
Attachment #8764648 - Flags: review?(mdeboer)
Comment on attachment 8764648 [details]
Bug 1281462 - Disable the modal highlight feature on Nightly for now.

https://reviewboard.mozilla.org/r/60380/#review57414
Attachment #8764648 - Flags: review-
Attachment #8764911 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 8764911 [details]
Bug 1281462 - Disable the modal highlight feature on Nightly for now.

https://reviewboard.mozilla.org/r/60516/#review57420

r=me assuming green try.

::: browser/app/profile/firefox.js
(Diff revision 1)
> -pref("findbar.highlightAll", true);
> -pref("findbar.modalHighlight", true);

It's not clear to me why we have this pref in 2 places, but I guess we're getting rid of this one - maybe if/when we re-enable, we can enable it directly in modules/libpref ?
(In reply to :Gijs Kruitbosch from comment #11)
> It's not clear to me why we have this pref in 2 places, but I guess we're
> getting rid of this one - maybe if/when we re-enable, we can enable it
> directly in modules/libpref ?

I was hesitant to impose this feature on SeaMonkey/ Thunderbird right away...
https://hg.mozilla.org/integration/fx-team/rev/afb7cb42a98a66de401af5bcf7de03733f2784cd
Bug 1281462 - Disable the modal highlight feature on Nightly for now. r=Gijs
Landed this morning: https://hg.mozilla.org/mozilla-central/rev/afb7cb42a98a
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Find toolbar was enabled on Nightly 52 and disabled on other channels(Aurora 51 and Beta 50). For More detail please see bug 1303248.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.