Allow me to go/step back in JS Debugger

RESOLVED DUPLICATE of bug 1145715

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED DUPLICATE of bug 1145715
2 years ago
a year ago

People

(Reporter: Jens, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox50 affected)

Details

(Reporter)

Description

2 years ago
This was raised as part of the top feature request in https://www.reddit.com/r/webdev/comments/3tl0f4/ask_rwebdev_what_could_firefoxs_devtools_do_better/

> While debugging I step through the code line by line. Most of the time 
> I know what I'm looking for and this works fine. Sometimes I don't know 
> what I'm looking for and so I have to click next a billion times. And 
> EVERY time I end up passing it. The ability to go backwards would be the 
> thing that sets FF apart and would make lots of people switch. This is 
> such a basic, daily need. I'm sure this would be a big engineering 
> challenge, but even if I could only go back a couple of steps, it would 
> be immensely helpful.

The JS debugger lets me step forward, but not step back. Surely, for technical reasons. Because from a UX point of view I naturally also want to be able to step back.
(Reporter)

Updated

2 years ago
(In reply to Jens from comment #0)
> This was raised as part of the top feature request in
> https://www.reddit.com/r/webdev/comments/3tl0f4/
> ask_rwebdev_what_could_firefoxs_devtools_do_better/
> 
> > While debugging I step through the code line by line. Most of the time 
> > I know what I'm looking for and this works fine. Sometimes I don't know 
> > what I'm looking for and so I have to click next a billion times. And 
> > EVERY time I end up passing it. The ability to go backwards would be the 
> > thing that sets FF apart and would make lots of people switch. This is 
> > such a basic, daily need. I'm sure this would be a big engineering 
> > challenge, but even if I could only go back a couple of steps, it would 
> > be immensely helpful.
> 
> The JS debugger lets me step forward, but not step back. Surely, for
> technical reasons. Because from a UX point of view I naturally also want to
> be able to step back.

Hi Jens,

This is one of the most requested features for the debugger. Unfortunately, it's also extremely hard to implement. Essentially, one would have to follow the same strategy that rr does: keep a record of all side-effects of a program, and then use that record to replay the execution up until an earlier point.

Needless to say, before the devtools team could even attempt to implement this, we would need significant platform support. My understanding is that bhackett has been working on an attempt to implement the platform side of this, but I don't know how far along that project is, or how feasible that implementation will be in the long run.

In any case, it will be some time before this bug will be actionable for the devtools team, so I'm marking at as P3 for the time being.

Hope that helps!
Priority: -- → P3
(Reporter)

Updated

2 years ago
Depends on: 1207696
See Also: bug 1207696

Comment 2

a year ago
Closing one of these as a dup.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145715
You need to log in before you can comment on or make changes to this bug.