Closed Bug 894997 Opened 7 years ago Closed 5 months ago

Make it possible to create/edit sources in the debugger

Categories

(DevTools :: Debugger, enhancement, P5)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 771339

People

(Reporter: bbenvie, Unassigned)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

The Sources View in the debugger should allow for creation and editing of files as well as executing them, much like the Scratchpad. This would be a good step toward combining the authoring and the debugging experience into one streamlined flow.
Priority: -- → P3
QA Contact: bbenvie
Assignee: nobody → bbenvie
QA Contact: bbenvie
Aw man, this would be so good. <3
The bug that I was talking about that had discussions are : bug 757254 and bug 771339 . This one is most probably a dupe of bug 771339.
Oh no, that's about actually replacing a function that's already being executed. This bug is mostly a Ui thing.
Blocks: 888161
Assignee: bbenvie → nobody
Summary: Make the Sources View in the debugger allow editing (embedded Scratchpad) → Make it possible to create/edit sources in the debugger
Depends on: 771339
See Also: → 1282039
See Also: 1282039
See Also: → 737743
Product: Firefox → DevTools
Type: defect → enhancement
Priority: P3 → P5
Blocks: 1565711
Blocks: 1565713
No longer blocks: 1565711
No longer blocks: 1565713
No longer blocks: 888161
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 771339
You need to log in before you can comment on or make changes to this bug.