If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Activity Stream resource is not removed from "about:preferences->Home Page" field after uninstalling the add-on

VERIFIED FIXED

Status

()

Firefox
Activity Streams: General
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: VladB, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox50 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8764888 [details]
Home Page resource not removed

[Affected versions]:
- Firefox 45.0 and up
- Activity Stream 1.1.0-dev

[Affected Platforms]:
- All Windows
- All Mac OS X
- All Linux

[Prerequisites]:
- Latest Activity Stream add-on version (1.1.0-dev) was previously installed on a clean profile.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites. 
2. Go to `about:preferences` and observe the Home Page resource.
3. Open `about:addons` in a new tab and click on "Remove" button.
4. Go back to `about:preferences` and observe the Home Page resource.

[Expected result]:
- Default Mozilla Firefox Start Page is set as Home Page.

[Actual result]:
- resource://activity-streams/data/content/activity-streams.html#/ is set as Home Page.

[Notes]:
- When Activity Stream add-on is disabled, the resource from Home Page is removed and Default Mozilla Firefox Start Page is set as Home Page.
- Attached a screen recording of the issue.
(Reporter)

Comment 1

a year ago
Filed in GitHub as https://github.com/mozilla/activity-stream/issues/882
(Reporter)

Comment 2

a year ago
via https://github.com/mozilla/activity-stream/pull/884/commits/7773215d80cef8dc3b44f95ee912f1be3d0b2647
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Reporter)

Comment 3

a year ago
This issue has been verified on Win 8.1 x64, Mac OS X 10.11 and Ubuntu 14.04 x64 with latest Nightly 50.0a1 (Build ID: 20160626030213) using latest Activity Stream v1.1.0-custom build and could not reproduce it.
Thus, marking this issue as Verified-Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.