Closed Bug 128243 Opened 20 years ago Closed 20 years ago

textbox focus() steals focus across tabs

Categories

(SeaMonkey :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: malsdavis, Assigned: jag+mozilla)

References

()

Details

(Keywords: polish)

I have noticed that when using tabbed browsing in mozzila 0.9.8 that if a page
executes a textbox.focus() javascript function (which is used to autmotically
focus the users typing cursor on a text box within a form), then this steals the
cursor from other tabbed pages.

A simple way to demonstrate this (although doesn't really show how annoying it
can be) is by first going to a page with a form, start typing in some text, then
open a new tab and type www.google.com in the URL bar, then quickly go back to
the first page and continue typing in the form. After a couple of seconds (i.e.
when the Google page has loaded so depending on your connection speed), you will
find you are suddenly no longer typing in the form on the first page but are now
entering stuff into the google search box despite google being in the background.
Upping severity to normal as it can be really annoying if you have slow
connection and regularly open more tabs on backgrounds and don't wait for them
to load.
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
OS: other → All
Hardware: PC → All
Summary: textbox focus() executes accross tabs → textbox focus() steals focus across tabs

*** This bug has been marked as a duplicate of 124750 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
vrfy dupe
Status: RESOLVED → VERIFIED
*** Bug 228641 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.