Closed Bug 228641 Opened 18 years ago Closed 18 years ago

old tab steals focus from new tab

Categories

(SeaMonkey :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: wvw, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Sometimes, when opening a new tab, the focus is not set to the location bar, but
stays on the previously selected and hidden tab. The old tab seems to steal the
focus from the new tab. 

Reproducible: Always

Steps to Reproduce:
1. Open a new browser window, type www.google.com in the location bar
2. Hit enter and immediately hit ctrl-t
3. Start typing the desired address for the new tab

(I have the 'Load links in background' option set to on. Google.com is just an
example, it always happens with pages setting the focus to a form)
Actual Results:  
The location bar isn't focussed. When I type, nothing seems to happen. But when
I go to the first tab, I see the text I typed appear in the form field of the
Google page.

Expected Results:  
Set the focus to the location bar, and only set the focus inside the hidden tab
page, not to the global Mozilla chrome. It must be the javascript focus command.

*** This bug has been marked as a duplicate of 128243 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
oops, sorry
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.