Closed Bug 1282737 Opened 4 years ago Closed 4 years ago

ipc::FatalError error message does not appear on Socorro

Categories

(Core :: IPC, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1278717

People

(Reporter: kanru, Assigned: kanru)

Details

Attachments

(2 obsolete files)

https://dxr.mozilla.org/mozilla-central/rev/2ab57664bf7cafdd64e136e341527c275fc8c3aa/ipc/glue/ProtocolUtils.cpp#476

In parent process we call CrashReporter::AnnotateCrashReport to record the messages but in content process we only use |NS_RUNTIMEABORT(formattedMessage.get())|

I'm not sure if it's only the messsage in FatalError not record or all NS_RUNTIMEABORT message is not recorded for content process.

Fix this will improve our ability to analyze crash reports.
Bug 1049275 made we only report abort messages for parent process so content process will not get the benefit of bug 803779.

Worse is in content process CrashReporter::AnnotateCrashReport needs to be on main-thread so revert bug 1049275 still can't give us reliable abort messages in crash reports.
Review commit: https://reviewboard.mozilla.org/r/61736/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/61736/
Attachment #8767053 - Flags: review?(wmccloskey)
Attachment #8767054 - Flags: review?(wmccloskey)
Attachment #8767054 - Flags: review?(benjamin)
This patch aims to bring AbortMessage annotation back to the child
process that is thread-safe and IPDL-safe. It uses a Shmem as the
abort message buffer that is shared between parent and child. When
child aborts, the parent process can safely reopen the sealed Shmem
segments and read the abort message from it. The child process may put
arbitrary data in the buffer so the data is still escaped in the
parent process.

Review commit: https://reviewboard.mozilla.org/r/61738/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/61738/
Assignee: nobody → kchen
Status: NEW → ASSIGNED
There is no need for all this complexity. aklotz already implemented "safe" crash annotations in bug 1236108 and we should use that mechanism.
Attachment #8767054 - Flags: review?(benjamin) → review-
Comment on attachment 8767054 [details]
Bug 1282737 - Use a Shmem to store abort message from child.

https://reviewboard.mozilla.org/r/61738/#review58602
For what it is worth, there's also bug 1259255 on this issue.
I think it would be better to do this via bug 1278717, which I think does what Benjamin is suggesting. I started working on it on Friday. Hopefully I'll have it done in a few days. It doesn't look too bad.
Thanks, Bill.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1278717
Attachment #8767053 - Attachment is obsolete: true
Attachment #8767054 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.