Closed Bug 12828 Opened 21 years ago Closed 20 years ago

Anyone can change a "new" bug to "Assigned" to someone else

Categories

(Bugzilla :: Bugzilla-General, defect, P3, major)

All
Windows NT

Tracking

()

VERIFIED DUPLICATE of bug 25273

People

(Reporter: dveditz, Assigned: justdave)

Details

I was viewing someone else's bug in the NEW state. Forgetting it was assigned
to someone else I selected "Accept" and hit the commit button. The bug changed
to the ASSIGNED state, still for that other person.

I would expect either
 - don't allow use of "accept" in this case
 - make it a shortcut for "reassign to me, then accept"
Status: NEW → ASSIGNED
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: ASSIGNED → NEW
Don--would this be covered by the permissions stuff?
Assignee: tara → donm
Status: NEW → ASSIGNED
I think only the person to whom it is assigned should be able to make the 
status ASSIGNED, no need for complicated permissions. Unless you take my second 
idea about making it a shortcut for reassign-and-accept in which case you'd 
need whatever level of permission checking to allow reassignments.
*** Bug 37613 has been marked as a duplicate of this bug. ***
dveditz, are you saying (example) that if a bug was a "New" to rickg and I 
wanted to set "Assigned" to karnaze per rickg's request, I could not do it?  
rickg would have to do it?  Cause that would not fly. Eng Mgrs, PDT, etc need to 
be able to reassign during bug triaging.  Is this what you want?  Can you give 
me an example?
This is a duplicate of bug 25273.
leger, yes, that's what is intended as lined out at

<http://bugzilla.mozilla.org/bug_status.html#assigned_to>.



Bug 25273 has a patch



*** This bug has been marked as a duplicate of 25273 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
vrfy
Status: RESOLVED → VERIFIED
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: donm → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.