Closed Bug 1282846 Opened 4 years ago Closed 4 years ago

[e10s] Mouse wheel scrolling disabled after using accessibility tools on Ubuntu

Categories

(Firefox :: General, defect, P3)

49 Branch
All
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1288751

People

(Reporter: JuliaC, Unassigned)

References

Details

(Keywords: regression)

[Note]:
- I reproduced this issue only on stations where Orca screen reader was previously used

[Affected versions]:
- latest Aurora 49.0a2 (2016-06-28)

[Affected platforms]:
- Ubuntu 12.04 x64
- Ubuntu 14.04 x86

[Steps to reproduce]:
1. Launch Orca screen reader, close it and then assure you closed any accessibility process
2. Launch Firefox with a new profile
3. Go to http://www.ubuntu.com/download/desktop -> click the Download button
4. Try to scroll through the "Help shape the future of Ubuntu…" page using the mouse wheel
5. In a new tab open a random long web page (e.g. http://edition.cnn.com/)
6. Try to scroll through this open web page using the mouse wheel
7. Go to about:support 
- inspect the "Multiprocess Windows" entry
8. Restart Firefox
- inspect the "Multiprocess Windows" entry
9. Try again to scroll through the previous open web pages using the mouse wheel 

[Expected result]:
- (steps 4, 6 and 9) The user is able to scroll through the open web pages, no matter what method he uses
- (step 7) e10s is enabled
- (step 8) Since there is no open accessibility process, e10s remains enabled

[Actual result]:
- (steps 4 and 6) The user can't scroll the open web pages using the mouse wheel 
- (step 7) e10s is disabled ("Disabled by accessibility tools" spec is displayed next to the "Multiprocess Windows" entry)

[Regression range]:
- This issue is reproducible starting with Aurora (2016-06-16), when the Bug 1277882 landed its fix

[Additional notes]:
- If Firefox is started with e10s disabled, the issue isn't encountered anymore
- I first met this issue on Firefox 48.0b4 build1 (20160627144420), but I couldn't reproduce it anymore on this build
- It seems that Nightly and RC builds are not affected
tracking-e10s: --- → ?
This sounds a lot like https://bugzilla.mozilla.org/show_bug.cgi?id=1233795

But if it's a regression from bug 1277882, moving to Firefox::General which is the component that bug was in. cc jimm as well to get it on his radar, although I presume it will go through e10s triage at some point.
Blocks: 1277882
Component: Panning and Zooming → General
Flags: needinfo?(jmathies)
Product: Core → Firefox
See Also: → 1233795
Whoops, didn't mean to needinfo.
Flags: needinfo?(jmathies)
Flags: needinfo?(twalker)
I can not reproduce carefully following the given STR's on latest Nightly 50.0a1 20160705030222 on ubuntu 14.04.2. Scroll wheel works at every page e10s is enabled as expected (since Orca was shut off completely before Nightly was started).
Flags: needinfo?(twalker)
(In reply to Tracy Walker [:tracy] from comment #3)
> I can not reproduce carefully following the given STR's on latest Nightly
> 50.0a1 20160705030222 on ubuntu 14.04.2. Scroll wheel works at every page
> e10s is enabled as expected (since Orca was shut off completely before
> Nightly was started).

Hello! I have to mention that this issue affects only Aurora 49 builds.
Flags: needinfo?(twalker)
I am able to reproduce this (sort of) on latest Dev-Edition 49.0a2, 20160714004054, on Ubuntu 14.04.2.

What I observed with a fresh profile:
after step 7: e10s is enabled, but pages can't be scrolled by mouse wheel except the about:support page.  Pages can be scrolled with the scroll bars.

after restarting (step 8):  e10s is disabled and the pages can be scrolled with any method.
Flags: needinfo?(twalker)
Priority: -- → P3
This is the same issue as bug 1288751.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
See Also: 1288751
Duplicate of bug: 1288751
Killing flags so that this doesn't appear on our triage list.

Kats you're sure this is the same bug right?
tracking-e10s: + → ---
Flags: needinfo?(bugmail)
Yup
Flags: needinfo?(bugmail)
You need to log in before you can comment on or make changes to this bug.