Disable e10s when we detect accessibility use on linux

VERIFIED FIXED in Firefox 48

Status

()

defect
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

Trunk
Firefox 50
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm9+, firefox48 verified, firefox49 verified, firefox50 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

The a11y team has decided not to allow a11y + e10s to run together for linux users in 48.
Posted patch wip (obsolete) — Splinter Review
Posted patch patchSplinter Review
Attachment #8759706 - Attachment is obsolete: true
Attachment #8760254 - Flags: review?(felipc)
David, do you know of any open source screen readers for ubuntu I can test this patch with?
Flags: needinfo?(dbolter)
(In reply to Jim Mathies [:jimm] from comment #4)
> David, do you know of any open source screen readers for ubuntu I can test
> this patch with?

Orca is what you want. The maintainer 'joanie' hangs out in our #accessibility channel.
Flags: needinfo?(dbolter)
(In reply to David Bolter [:davidb] from comment #5)
> (In reply to Jim Mathies [:jimm] from comment #4)
> > David, do you know of any open source screen readers for ubuntu I can test
> > this patch with?
> 
> Orca is what you want. The maintainer 'joanie' hangs out in our
> #accessibility channel.

Thanks. I've confirmed the appropriate prefs get set with this patch.
Attachment #8760254 - Flags: review?(felipc) → review+
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/9227c07f1c80
Disable e10s on Linux when recent accessibility use is detected. r=felipe
Keywords: checkin-needed
Blocks: 1278568
https://hg.mozilla.org/mozilla-central/rev/9227c07f1c80
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Comment on attachment 8760254 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]:
disable e10s if we detect a11y use on linux
[User impact if declined]:
crashy browser with a11y use
[Describe test coverage new/current, TreeHerder]:
in nightly for a couple builds.
[Risks and why]: 
pretty low, code is in use on other platforms. this change adds it to linux builds. 
[String/UUID change made/needed]:
none
Attachment #8760254 - Flags: approval-mozilla-beta?
Attachment #8760254 - Flags: approval-mozilla-aurora?
Comment on attachment 8760254 [details] [diff] [review]
patch

"Improve" e10s, taking it. Should be in 48 beta 2.
Attachment #8760254 - Flags: approval-mozilla-beta?
Attachment #8760254 - Flags: approval-mozilla-beta+
Attachment #8760254 - Flags: approval-mozilla-aurora?
Attachment #8760254 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
Hello! 
I investigated this issue on 
- latest Nightly 50.0a1 (2016-06-23)
- latest Aurora 49.0a2 (2016-06-23)
- 48.0b2 build2 (20160620091522)
using Ubuntu 14.04 x86. 
I turned on some accessibility features, like "Caret Browsing", "Search for text when I start typing" and "Page Zoom", but e10s seems to be still enabled (like about:support and about:config indicates). 
Is there another way for verifying this bug or Firefox didn't detect a11y?
Thank you in advance!
Flags: needinfo?(jmathies)
(In reply to Iulia Cristescu, QA [:IuliaC] from comment #12)
> Hello! 
> I investigated this issue on 
> - latest Nightly 50.0a1 (2016-06-23)
> - latest Aurora 49.0a2 (2016-06-23)
> - 48.0b2 build2 (20160620091522)
> using Ubuntu 14.04 x86. 
> I turned on some accessibility features, like "Caret Browsing", "Search for
> text when I start typing" and "Page Zoom", but e10s seems to be still
> enabled (like about:support and about:config indicates). 
> Is there another way for verifying this bug or Firefox didn't detect a11y?
> Thank you in advance!

You have to test with a 3rd party accessibility client. See comment 4 and comment 5.
Flags: needinfo?(jmathies)
(In reply to Jim Mathies [:jimm] from comment #13)
> (In reply to Iulia Cristescu, QA [:IuliaC] from comment #12)
> > Hello! 
> > I investigated this issue on 
> > - latest Nightly 50.0a1 (2016-06-23)
> > - latest Aurora 49.0a2 (2016-06-23)
> > - 48.0b2 build2 (20160620091522)
> > using Ubuntu 14.04 x86. 
> > I turned on some accessibility features, like "Caret Browsing", "Search for
> > text when I start typing" and "Page Zoom", but e10s seems to be still
> > enabled (like about:support and about:config indicates). 
> > Is there another way for verifying this bug or Firefox didn't detect a11y?
> > Thank you in advance!
> 
> You have to test with a 3rd party accessibility client. See comment 4 and
> comment 5.

Thank you for your clarification. I tested this bug on
- latest Nightly 50.0a1 (2016-06-27)
- latest Aurora 49.0a2 (2016-06-27)
- 48.0b3 build1 (20160623122823) 
using Orca screen reader, Ubuntu 14.04 x86 and Ubuntu 14.04 x64.
On Nightly build, Firefox seems not to detect accessibility (e10s is still enabled - like about:support, about:preferences and about:config indicate).
On Aurora and Beta, Firefox detects accessibility only after restart, e10s being successfully disabled. But e10s isn't enabled after the screen reader process is closed and Firefox restarted - I couldn't enable e10s changing the browser.tabs.remote.autostart preference state; also, on Aurora build, the "Enable multi-process" option remains greyed out. Are these expected?
(In reply to Iulia Cristescu, QA [:IuliaC] from comment #14)
> (In reply to Jim Mathies [:jimm] from comment #13)
> > (In reply to Iulia Cristescu, QA [:IuliaC] from comment #12)
> > > Hello! 
> > > I investigated this issue on 
> > > - latest Nightly 50.0a1 (2016-06-23)
> > > - latest Aurora 49.0a2 (2016-06-23)
> > > - 48.0b2 build2 (20160620091522)
> > > using Ubuntu 14.04 x86. 
> > > I turned on some accessibility features, like "Caret Browsing", "Search for
> > > text when I start typing" and "Page Zoom", but e10s seems to be still
> > > enabled (like about:support and about:config indicates). 
> > > Is there another way for verifying this bug or Firefox didn't detect a11y?
> > > Thank you in advance!
> > 
> > You have to test with a 3rd party accessibility client. See comment 4 and
> > comment 5.
> 
> Thank you for your clarification. I tested this bug on
> - latest Nightly 50.0a1 (2016-06-27)
> - latest Aurora 49.0a2 (2016-06-27)
> - 48.0b3 build1 (20160623122823) 
> using Orca screen reader, Ubuntu 14.04 x86 and Ubuntu 14.04 x64.
> On Nightly build, Firefox seems not to detect accessibility (e10s is still
> enabled - like about:support, about:preferences and about:config indicate).
> On Aurora and Beta, Firefox detects accessibility only after restart, e10s
> being successfully disabled. But e10s isn't enabled after the screen reader
> process is closed and Firefox restarted - I couldn't enable e10s changing
> the browser.tabs.remote.autostart preference state; also, on Aurora build,
> the "Enable multi-process" option remains greyed out. Are these expected?

Yes, this sounds correct.
(In reply to Jim Mathies [:jimm] from comment #15)

> Yes, this sounds correct.
Thank you! I will set the flags accordingly. 

What about
> > On Nightly build, Firefox seems not to detect accessibility (e10s is still
> > enabled - like about:support, about:preferences and about:config indicate).
?
I tested the bug again on Ubuntu 14.04 x86 and Ubuntu 12.04 x86, using the latest Nightly 50.0a1 (2016-06-29) and the above mentioned problem still occurs.
I can still reproduce the bug on latest Nightly 50.0a1 (2016-07-19) using Ubuntu 14.04 x86 and Orca screen reader. As I mentioned in above comments, Firefox seems not to detect accessibility (e10s is still enabled - like about:support, about:preferences and about:config indicate), even after repeatedly restart. Any thoughts about this?
Flags: needinfo?(jmathies)
(In reply to Iulia Cristescu, QA [:IuliaC] from comment #17)
> I can still reproduce the bug on latest Nightly 50.0a1 (2016-07-19) using
> Ubuntu 14.04 x86 and Orca screen reader. As I mentioned in above comments,
> Firefox seems not to detect accessibility (e10s is still enabled - like
> about:support, about:preferences and about:config indicate), even after
> repeatedly restart. Any thoughts about this?

This is correct behavior, we left a11y+e10s on in nightly for testing purposes.
Flags: needinfo?(jmathies)
(In reply to Jim Mathies [:jimm] from comment #18)
> (In reply to Iulia Cristescu, QA [:IuliaC] from comment #17)
> > I can still reproduce the bug on latest Nightly 50.0a1 (2016-07-19) using
> > Ubuntu 14.04 x86 and Orca screen reader. As I mentioned in above comments,
> > Firefox seems not to detect accessibility (e10s is still enabled - like
> > about:support, about:preferences and about:config indicate), even after
> > repeatedly restart. Any thoughts about this?
> 
> This is correct behavior, we left a11y+e10s on in nightly for testing
> purposes.

Ok! Thanks for your clarification! Based on last comments, I will set the flags accordingly.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.