Closed Bug 1282972 Opened 3 years ago Closed 3 months ago

Handle storage quotas for extension origins

Categories

(WebExtensions :: Storage, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mattw, Assigned: rpl)

References

Details

(Whiteboard: triaged)

No longer blocks: 1280062
Blocks: 1280062
Whiteboard: [webNavigation] triaged → triaged
This includes adding support for the "unlimitedStorage" permission.

I've noticed some errors generated by quota checking code for extension origins, so those will have to be fixed first.
Summary: Implement "unlimitedStorage" permission → Handle storage quotas for extension origins
Duplicate of this bug: 1322101
Duplicate of this bug: 1331618
webextensions: --- → ?
webextensions: ? → ---
Component: WebExtensions: Untriaged → WebExtensions: Storage
Assuming that this could be easier as part of the storage.local to indexed DB changes. Might even come for free.
Assignee: nobody → lgreco
Depends on: 1406181
Product: Toolkit → WebExtensions

I'm closing this issue, the storage quota is now checked by extension origin as part of the storage.local IndexedDB backend.

In Bug 1555491 we also added some additional tests explicitly related to the QuotaExceededError scenarios.

Status: NEW → RESOLVED
Closed: 3 months ago
Depends on: 1488825
Resolution: --- → FIXED
See Also: → 1555491
Depends on: 1496801
You need to log in before you can comment on or make changes to this bug.