Closed Bug 1283573 Opened 3 years ago Closed 3 years ago

[10.12] Prompted to download font "Osaka" on startup - please see bug 1315752 if you still experience this problem.

Categories

(Core :: Widget: Cocoa, defect)

All
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla50
Tracking Status
firefox48 --- verified
firefox49 --- verified
firefox50 --- verified

People

(Reporter: mstange, Assigned: jfkthame)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

When launching Firefox on 10.12, the following message appears:

> Nightly needs to download font “Osaka” before use.
> 1.4 MB to download in total.
> 
>                            [Download]   [Skip]
This happens when we call CGFontCreateWithFontName in gfxMacPlatformFontList::LookupLocalFont for the font "Osaka-mono".
LookupLocalFont is called from gfxMacPlatformFontList::InitSingleFaceList which is called during gfxPlatform::Init().
The whole InitSingleFaceList thing seems like kind of an ugly hack to me. AIUI, this exists just to make "Osaka-mono" work as a value for font-family, even though it doesn't show up as a family in the normal font collection. Given that it has such a narrow purpose, maybe we could tweak how it works such that it doesn't attempt to look up the Osaka-mono face if the Osaka family isn't available.
I wonder if we could do something like this. Does this prevent the unwanted prompt on startup?
Attachment #8766885 - Flags: review?(mstange)
Comment on attachment 8766885 [details] [diff] [review]
Don't attempt to look up a single-face-family name if the corresponding main family isn't available

Review of attachment 8766885 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! I've confirmed that the patch works as intended and the dialog doesn't come up any more. Then I installed Osaka by starting Thunderbird and choosing "Download" on the dialog.

Excerpt from the fontlist log, with the patch applied, before I installed Osaka:

[Main Thread]: D/fontlist (fontlist-singleface) face name: Osaka-Mono:Osaka
[Main Thread]: D/fontlist (fontlist) added (.AppleSystemUIFont) to family (.SF NS Text) with style: normal weight: 400 stretch: 0 (apple-weight: 5 macTraits: 00004000)
[...]

and after I installed Osaka:

[Main Thread]: D/fontlist (fontlist-singleface) face name: Osaka-Mono:Osaka
[Main Thread]: D/fontlist (fontlist-singleface) family name: Osaka-Mono, key: osaka-mono
[Main Thread]: D/fontlist (fontlist-singleface) added new family
[Main Thread]: D/fontlist (fontlist) added (.AppleSystemUIFont) to family (.SF NS Text) with style: normal weight: 400 stretch: 0 (apple-weight: 5 macTraits: 00004000)
[...]
Attachment #8766885 - Flags: review?(mstange) → review+
And, unsurprisingly, the patch does not fix bug 1279962.
Assignee: nobody → jfkthame
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/eb6de343924f
Don't attempt to look up a single-face-family name if the corresponding main family isn't available. r=mstange
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/eb6de343924f
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Duplicate of this bug: 1286715
Comment on attachment 8766885 [details] [diff] [review]
Don't attempt to look up a single-face-family name if the corresponding main family isn't available

Approval Request Comment
[Feature/regressing bug #]: no regression; issue triggered by MacOS update with new download-on-first-use system for some formerly-preinstalled fonts

[User impact if declined]: users on upcoming MacOS 10.12 (sierra) likely to get an unwanted font-download prompt when starting Firefox

[Describe test coverage new/current, TreeHerder]: verified manually (comment 4)

[Risks and why]: minimal - just adds a check for the presence of the font family before trying to look up an individual face

[String/UUID change made/needed]: none
Attachment #8766885 - Flags: approval-mozilla-aurora?
Do we need this on beta as well? Looks like 49 will be initially released the middle of september, and Sierra in about the same timeframe, so it might be a good idea to get this into 48 as well if the patch is safe?
Flags: needinfo?(jfkthame)
Comment on attachment 8766885 [details] [diff] [review]
Don't attempt to look up a single-face-family name if the corresponding main family isn't available

I think the patch is safe enough we could take it for 48, but we are quite a long way through Beta already, so I don't know if release managers will accept it? Adding mozilla-beta request for consideration; see above for details.
Flags: needinfo?(jfkthame)
Attachment #8766885 - Flags: approval-mozilla-beta?
Comment on attachment 8766885 [details] [diff] [review]
Don't attempt to look up a single-face-family name if the corresponding main family isn't available

Let's try this on 48. We still have several betas left before the Aug. 2 release, and I like the idea of avoiding that prompt.
Attachment #8766885 - Flags: approval-mozilla-beta?
Attachment #8766885 - Flags: approval-mozilla-beta+
Attachment #8766885 - Flags: approval-mozilla-aurora?
Attachment #8766885 - Flags: approval-mozilla-aurora+
We should verify the fix on beta once this lands.
VERIFIED FIXED on macOS 10.12 Sierra Developer Preview 2 (16A239j) on:
- Nightly 50.0a1 (id: 20160720030208)
- latest DevEdition 49.0a2 (id: 20160720004018)
- Beta 48.0b9 (id: 20160718142219)
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1296106
Copied over from bug 1279962 comment 53:

> I'm not a programmer user, I got the error described here in which
> "plugin-container.app" asks me to download the font Osaka. Looking to solve
> the problem on the Internet, this thread was the unique result related to
> this bug.
> 
> At this time (Firefox 49.0.1, MacBook Air OSX Sierra 10.12) I get this
> message every time I click to start a new search, that is almost all the
> time.

This was supposed to have been fixed for Fx48 and upwards. Any ideas, Markus? Can you reproduce? (Not yet on Sierra here...)
Flags: needinfo?(mstange)
It does not happen for me, but I have Osaka installed (ever since I clicked "Download" in this very dialog) and I don't see an easy way to uninstall it again.

tito, when you open the app "Font Book" and search for Osaka, does it find any fonts?
Flags: needinfo?(mstange) → needinfo?(tito)
You can't do <<File / Remove "Osaka" Family>> in Font Book? On El Capitan, it looks like that's possible (it's only disabled for families installed in /System/Library/Fonts, not /Library/Fonts).

Is it installed as a normal font file in /Library/Fonts, or did it get installed via some new method on Sierra?
(In reply to Jonathan Kew (:jfkthame) from comment #19)
> You can't do <<File / Remove "Osaka" Family>> in Font Book? On El Capitan,
> it looks like that's possible (it's only disabled for families installed in
> /System/Library/Fonts, not /Library/Fonts).

This menu item is greyed out for me on 10.12.

> Is it installed as a normal font file in /Library/Fonts, or did it get
> installed via some new method on Sierra?

There is no Osaka.ttf in /Library/Fonts, or any other file that contains the string "Osaka" in its filename. But /Library/Fonts/fonts.list lists Osaka with a non-existing filename:
/Library/Fonts//Osaka.ttf
/Library/Fonts//OsakaMono.ttf

Osaka is also not present in /System/Library/Fonts.

The only Osaka.ttf on my system is in /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/Support/FontSubsets/ .
Interesting, so they're not simply downloading a file and dumping it in the Fonts folder, as if you'd installed it manually. Given the fonts.list entry, though, I wonder if it *is* actually in /Library/Fonts, but hidden from the usual file list in some way? Can "sudo ls -la /Library/Fonts" or something like that see it?
That doesn't show it either.
Indeed not. I guess it's just some kind of Apple magic...
Hi,

Yes, I have a font called Osaka in the Font Book:
https://drive.google.com/file/d/0B1-XpO8HnO7TOGw4NWVjcXlLdHM/view?usp=sharing

but oddly the font not seems to be in /Library/Fonts/

The message always emerges at the same time, by clicking on the search box after opening a new tab. I made a short video reproducing the error:
https://drive.google.com/file/d/0B1-XpO8HnO7TcDJJQ0JxQ3p1MkE/view?usp=sharing

Regards,
Flags: needinfo?(tito)
(In reply to tito from comment #24)
> Yes, I have a font called Osaka in the Font Book:
> https://drive.google.com/file/d/0B1-XpO8HnO7TOGw4NWVjcXlLdHM/view?usp=sharing

The interesting part about this screenshot is that only the Mono variant is greyed out, but the Regular ("Normal" in your locale) variant is not. On my machine, both are greyed out. On my machine, both variants are greyed out.

Can you run this command in Terminal.app and paste the output here?

sudo find / -name Osaka*.ttf 2> /dev/null

It will tell us where on your machine the Osaka files are.
Hi Markus, the output was:

/System/Library/Assets/com_apple_MobileAsset_Font3/0412b97ba362b3017d1f5d445681f7912d13823b.asset/AssetData/Osaka.ttf

/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/Support/FontSubsets/Osaka.ttf

/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/Support/FontSubsets/OsakaMono.ttf
Huh, so weird. Thanks! Can you also attach the contents of /Library/Fonts/fonts.list?
Searching with sudo find / -name fonts.list  2> /dev/null I can't find such file (0 results). Anyway, the list of fonts in my Sierra installation are:

System/Library/Fonts
https://drive.google.com/file/d/0B1-XpO8HnO7TREwtS2xEc0VEZzg/view?usp=sharing

/Library/Fonts
https://drive.google.com/file/d/0B1-XpO8HnO7TeHQ4b3VPczlKNGc/view?usp=sharing
Still broken in 49.0.2 on OSX 10.12.
(In reply to Cameron from comment #29)
> Still broken in 49.0.2 on OSX 10.12.

Often happens when I create a new tab (with the 5x3 tiled web page thumb-nails.)

MOST DEFINITELY NOT FIXED.
Markus, would it make sense to file a followup to investigate cases where this is still hitting people?
Flags: needinfo?(mstange)
I'm getting a pop-up to install this font each time I open a new tab. Still broken in 49.0.2 on OSX 10.12.
I'm also seeing this pop-up: plugin-container needs to download the font “Osaka”. When starting a new tab so definitely still an issue.  Mac OS Sierra - 10.12.1  FF 49.0.2
A temporary workaround is to turn off "Allow pages to choose their own fonts, instead of my selections above" in FF content preferences. Problematic for designers though.
(In reply to B from comment #34)
> A temporary workaround is to turn off "Allow pages to choose their own
> fonts, instead of my selections above" in FF content preferences.
> Problematic for designers though.

Scratch that workaround only works sometimes...weird thing is leaving a tab open to about:preferences#content appears to stop the annoying missing font nag.
I filed bug 1315752 to investigate further for people who are still seeing this. I've attempted to CC everybody who commented here recently saying it's still broken for them. It would be helpful if you could comment there to see if we can narrow down the circumstances in which this happens, by trying a new Firefox profile and/or Firefox safe mode.
Flags: needinfo?(mstange)
Depends on: 1315752
I see it on 45.4.0 when I open a new tab.  OSX 10.12.1 .  What other information can I gather?
I see it on 45.4.0 when I open a new tab.  OSX 10.12.1 .  What other information can I gather?
(In reply to tbegush from comment #38)
> I see it on 45.4.0 when I open a new tab.  OSX 10.12.1 .  What other
> information can I gather?

Please see bug 1315752.

The best thing I can think of is using XCode/lldb/gdb on a nightly build on a machine where this reproduces and figuring out what's triggering this.
As far as I can tell, this only happens with a new tab, and only if the "Show your top sites" option is set (from the little gear up on the top right of the page when you open a new tab). By changing it to "Show blank page", I have been able to avoid these, and now to test (after a week of none of these errors), I have clicked the "Show your top sites" option back on on a blank tab and I _INSTANTLY_ got this error! (Even stranger, when I then clicked on "Show blank page" to put it back to the way that doesn't generate the error, I _INSTANTLY_ got the error again!)
Hello, i just change my OS of imac in sierra 10.12.1 and my version of firefox is 50.0.

I have the same bug :

In french :
plugin-container doit télécharger la police "osaka"
"osaka" fait 1,4 Mo
download / skip


I try the differents solution that i have read above but they dont work.

If anybody can help me, it will be very nice :)
apparently, this can work :

when you open a new tab, there is a “gear” at the upper right of the page. click on the gear and check the “show blank page” option.
THIS bug SHOULD NOT be labelled as *VERIFIED FIXED* it is *not fixed* as far as i see in my own environment. 

Fully patched macOS 10.12.1 running fully patched Firefox 50.0.1 STILL triggers the Osaka font download window anytime a new blank tab is opened.
agreed with Sean Kerner : 
i just write a tips but the bug isnt solve for me no more.
thks
macOS 10.12.2 with Firefox 45.5.1esr(DE) seems to be fixed, but Thunderbird 45.5.1(DE) is still showing the "download font osaka" message at startup.

fast and dirty workaround:
cp -a '/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/Support/FontSubsets/Osaka.ttf' /Library/Fonts
cp -a '/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/Support/FontSubsets/OsakaMono.ttf' /Library/Fonts
Another month and confirming still unfixed in Thunderbird 45.6.0. Another somewhat less intrusive work round: `cd ~/Library/Fonts; ln -s $(locate '*Osaka.ttf') .` (and perhaps the same for OsakaBold.)
same here. Thunderbird 45.6.0 under OS X Sierra 10.12.2 prompts for download of font osaka each time  it's started.
I'm seeing reports of this on Twitter with the upgrade to Firefox 51. Should this be re-opened?
(In reply to Asa Dotzler [:asa] from comment #48)
> I'm seeing reports of this on Twitter with the upgrade to Firefox 51. Should
> this be re-opened?

For the benefit of everyone else: we don't normally reopen bugs unless we have to take out whatever code changes landed for it. Even if the same problem reoccurs, we use new bugs, in order to make sure we accurately track when what changes make it to what branch of development.

In the case of this bug, the bug you want to look at is bug 1315752. If someone has more information that can help track down specifically when / in what cases this happens (as it doesn't happen to everyone using 10.12 or Firefox 51/52/nightly/whatever), that would be helpful -- but it should be on that bug.
Summary: [10.12] Prompted to download font "Osaka" on startup → [10.12] Prompted to download font "Osaka" on startup - please see bug 1315752 if you still experience this problem.
Possible fix, though for me, the Edit option is greyed out in Font Book.  
http://grannyjoans.blogspot.com/2017/01/annoying-message-plugin-container-app.html
(In reply to Kort from comment #50)
> Possible fix, though for me, the Edit option is greyed out in Font Book.  
> http://grannyjoans.blogspot.com/2017/01/annoying-message-plugin-container-
> app.html

apparently it worked for me: the Font book downloaded Osaka-mono and at restart TB did no more ask for Osaka font (checked with 5/6 restarts)
(In reply to mauriz from comment #51)
> (In reply to Kort from comment #50)
> > Possible fix, though for me, the Edit option is greyed out in Font Book.  
> > http://grannyjoans.blogspot.com/2017/01/annoying-message-plugin-container-
> > app.html
> 
> apparently it worked for me: the Font book downloaded Osaka-mono and at
> restart TB did no more ask for Osaka font (checked with 5/6 restarts)

Sadly, it stopped working form me shortly after it seemed fixed. I have not tried it again.
(In reply to Kort from comment #52)
> (In reply to mauriz from comment #51)
> > (In reply to Kort from comment #50)
> > > Possible fix, though for me, the Edit option is greyed out in Font Book.  
> > > http://grannyjoans.blogspot.com/2017/01/annoying-message-plugin-container-
> > > app.html
> > 
> > apparently it worked for me: the Font book downloaded Osaka-mono and at
> > restart TB did no more ask for Osaka font (checked with 5/6 restarts)
> 
> Sadly, it stopped working form me shortly after it seemed fixed. I have not
> tried it again.

Okay, I tried it again, Downloading from a button in the upper right of the display window. It is working thus far.
You need to log in before you can comment on or make changes to this bug.