Closed Bug 1284264 Opened 3 years ago Closed 3 years ago

Thunderbird release automation shouldn't touch mozilla-* versions on default

Categories

(Release Engineering :: Release Automation: Other, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rail, Assigned: rail)

References

Details

Attachments

(1 file)

see https://hg.mozilla.org/releases/mozilla-esr45/rev/188615976db5, https://hg.mozilla.org/releases/mozilla-esr45/rev/0745c581ec5f

I'm going to fix the current version and make sure it doesn't happen again.
(In reply to Rail Aliiev [:rail] from comment #2)
> Pushed fix: https://hg.mozilla.org/releases/mozilla-esr45/rev/d5b5d3e88b56

Are you sure that's right ? I was expecting to see the undoing of these
 https://hg.mozilla.org/releases/mozilla-esr45/rev/188615976db5
 https://hg.mozilla.org/releases/mozilla-esr45/rev/188615976db5

aka, we should have an esr suffix in the version.
Comment on attachment 8767691 [details]
Bug 1284264 - Thunderbird release automation shouldn't touch mozilla-* versions on default

https://reviewboard.mozilla.org/r/62118/#review58962

Looks good to me. BTW, our hg out and hg push code doesn't use '-r .', so we're in for fun if we start using a unified gecko repo.
Attachment #8767691 - Flags: review?(nthomas) → review+
(In reply to Nick Thomas [:nthomas] from comment #6)
> Looks good to me. BTW, our hg out and hg push code doesn't use '-r .', so
> we're in for fun if we start using a unified gecko repo.

Lalalallala :D

Jokes aside, yes, we should revisit a lot of things when we start using a unified gecko repo.
Comment on attachment 8767691 [details]
Bug 1284264 - Thunderbird release automation shouldn't touch mozilla-* versions on default

https://hg.mozilla.org/build/tools/rev/0a9b2d8b7efb
Attachment #8767691 - Flags: checked-in+
Duplicate of this bug: 1280634
Assuming this is done
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.