Embedded Dailymotion player doesn't load the video

RESOLVED WORKSFORME

Status

()

defect
P1
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: epinal99-bugzilla2, Assigned: jya)

Tracking

({regression, regressionwindow-wanted})

47 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 wontfix, firefox51 wontfix, firefox52 affected, firefox53 affected)

Details

(Whiteboard: [mozfr-community])

STR:
Load the page http://www.lequipe.fr/Football/Actualites/Video-le-chef-d-oeuvre-de-hal-robson-kanu-contre-la-belgique/701868 and play the video (in the tweet quote).

Result: the video doesn't load, you see only three points indicating loading.

I think it regressed in FF47 but I got different regression ranges each time I try.
Whiteboard: [mozfr-community]
"Video is geo-restricted by the owner". Hmph. I wonder if it is related to bug 1279507.
Yeah, I forgot that, to test the issue, you should be probably in France to avoid georestriction.
Firefox: 50.0a1, Build ID: 20160705030222
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

I have tested this issue on the latest Firefox (47.0.1) release and the latest Nightly (50.0a1) build, but I could not reproduce it. Considering the fact that the video is geo-restricted by the owner, I have used some France Proxies in order to test this. 
I have loaded the provided page, pressed the play button from the video, the 3 points have appeared and the video started playing after a ~10-20 seconds.

Loic, is this issue still reproducible with a new clean profile?
Flags: needinfo?(epinal99-bugzilla2)
Yes, it's reproducible with a clean profile because I used Mozregression a lot and each time a new profile is created and used.
The issue is even reproducible with old versions like FF37, but the issue is sporadic.
Flags: needinfo?(epinal99-bugzilla2)
Does the video play in Firefox if you download it and play it locally?
Guillaume - any ideas why this doesn't work in Firefox 47?
Hi Anthony, I just checked on Win7-x86-64, FF 47.0.1 and I was not able to reproduce.
However I was able to get this buffering state at the end of the video (while player is trying to load the postroll), which seems to be related to a JS runtime exception. we will investigate.

could you tell me if it was reproduced with Dailymotion Flash or HTML5 player ?
Flags: needinfo?(epinal99-bugzilla2)
(In reply to g.du.pontavice from comment #7)
> could you tell me if it was reproduced with Dailymotion Flash or HTML5
> player ?

It's with the embedded  HTML5 player. If you want to reproduce the issue, disable Flash in Firefox settings and reload the page with the video.
Flags: needinfo?(epinal99-bugzilla2)
Jean-Yves - any idea what is going on here?
Flags: needinfo?(jyavenard)
There are known reports about HLS.js loading video with gaps > 125ms.. Maybe we should increase our gap detection threshold to be more lenient about it. 500ms sound like a good number
Flags: needinfo?(jyavenard)
Depends on: 1297580
Assignee: nobody → jyavenard
Any updates on this bug, jya?
Flags: needinfo?(jyavenard)
always works for me...
Using Nightly on Linux.
Let's close it.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(jyavenard)
You need to log in before you can comment on or make changes to this bug.