Closed Bug 1284440 Opened 5 years ago Closed 5 years ago

Rendering issue occurs after restarting without HWA (or in Safe Mode) in OS X

Categories

(Core :: Graphics: Layers, defect)

Unspecified
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla50
Tracking Status
firefox50 --- verified

People

(Reporter: magicp.jp, Assigned: mtseng)

References

(Blocks 1 open bug)

Details

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160704030211

Steps to reproduce:

1. Start Nightly in OS X
2. Restart in Safe Mode
3. Open Bookmarks sidebar


Actual results:

Rendering issue occurs after restarting in Safe Mode. Especially when opening sidebar. (I can reproduce this issue in Yosemite and El Capitan)


Expected results:

Rendering works in Safe Mode
Has STR: --- → yes
Component: Untriaged → Graphics: Layers
OS: Unspecified → Mac OS X
Product: Firefox → Core
Checking.
Assignee: nobody → mtseng
Another STR:
Start Nightly without hardware acceleration in OS X
Summary: Rendering issue occurs after restarting in Safe Mode in OS X → Rendering issue occurs after restarting without HWA (or in Safe Mode) in OS X
Duplicate of this bug: 1284506
CreateRenderTargetForWindow might clear too aggressive which means it would clear unwanted area.
So I add ClipToRegion in advance to prevent it from clearing those unwanted area.
Attachment #8768328 - Flags: review?(matt.woodrow)
Attachment #8768328 - Flags: review?(matt.woodrow) → review+
Try looks good. The orange happened on OSX is caused by another commit.
Pushed by mtseng@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c8700e65f41b
Prevent CreateRenderTargetForWindow from clearing unwanted area. r=mattwoodrow
https://hg.mozilla.org/mozilla-central/rev/c8700e65f41b
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Depends on: 1285243
We should back this out.
Backed this out for graphic issues on Linux, see bug 1285243.
Flags: needinfo?(mtseng)
Backout by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/63cc31d6cc1c
Backed out changeset c8700e65f41b for causing graphic issues (bug 1285243). r=backout
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #8768328 - Attachment is obsolete: true
Pushed by mtseng@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2ada5807b65d
Prevent CreateRenderTargetForWindow from clearing unwanted area. r=mattwoodrow
https://hg.mozilla.org/mozilla-central/rev/2ada5807b65d
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Flags: needinfo?(mtseng)
Morris, can you add a test that would've caught the bug in the original patch?
Flags: needinfo?(mtseng)
I believe Michael is doing this. Michael, can you file a follow-up bug for this test case? Thanks.
Flags: needinfo?(mtseng) → needinfo?(cleu)
Yes, I'm investigating this issue.
I have filed a follow-up bug.
bug1287986
Flags: needinfo?(cleu)
Flags: qe-verify+
I was able to reproduce this issue on an older Nightly 50.0a1 from 2016-07-05.

The is verified fixed on Firefox 50.0b3-build1 (2016-09-29) running Mac OS X 10.10 and 10.11.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.