Closed Bug 1284726 Opened 3 years ago Closed 3 years ago

dom/media/DOMMediaStream.cpp:13:10: fatal error: 'mozilla/dom/MediaStreamTrackEvent.h' file not found (with disable-eme/disable-webrtc)

Categories

(Core :: Audio/Video: MediaStreamGraph, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 --- fixed

People

(Reporter: mats, Assigned: jib)

References

Details

(Whiteboard: [good-first-bug])

Attachments

(2 files)

STEPS TO REPRODUCE
1. put these lines in .mozconfig
ac_add_options --disable-webrtc
ac_add_options --disable-eme
2. build

ACTUAL RESULT
In file included from dom/media/Unified_cpp_dom_media0.cpp:137:
dom/media/DOMMediaStream.cpp:13:10: fatal error: 'mozilla/dom/MediaStreamTrackEvent.h' file not found
#include "mozilla/dom/MediaStreamTrackEvent.h"
         ^
1 error generated.
I'm also seeing this with today's (20160706) nightly.  I have disable-webrtc, but not the disable-eme.  That must be default.  These are my compile options.

0:06.63 Adding configure options from /home/stan/.mozconfig
 0:06.63   --enable-application=browser
 0:06.63   --enable-application=browser
 0:06.63   --prefix=/usr/local
 0:06.63   --with-pthreads
 0:06.63   --enable-default-toolkit=cairo-gtk3
 0:06.63   --enable-safe-browsing
 0:06.63   --enable-url-classifier
 0:06.63   --enable-gio
 0:06.63   --enable-chrome-format=omni
 0:06.63   --enable-bundled-fonts
 0:06.63   --with-x
 0:06.63   --with-ccache
 0:06.63   --enable-extensions=default
 0:06.63   --disable-gamepad
 0:06.63   --disable-webspeech
 0:06.63   --disable-accessibility
 0:06.63   --disable-webrtc
 0:06.63   --disable-webapp-runtime
 0:06.63   --disable-websms-backend
 0:06.63   --disable-android-omx
 0:06.63   --disable-tests
 0:06.63   --disable-necko-wifi
 0:06.63   --disable-updater
 0:06.63   --disable-parental-controls
 0:06.63   --disable-debug
 0:06.63   --with-intl-api
 0:06.63   --enable-optimize= -Wall -fno-schedule-insns2 -fno-lifetime-dse -fno-delete-null-pointer-checks -O3

15:12.34 In file included from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dom/media/Unified_cpp_dom_media0.cpp:137:0:
15:12.34 /mnt/to_archive/accum/src/mozilla-central/dom/media/DOMMediaStream.cpp:13:47: fatal error: mozilla/dom/MediaStreamTrackEvent.h: No such file or directory
15:12.34  #include "mozilla/dom/MediaStreamTrackEvent.h"
15:12.34                                                ^
15:12.34 compilation terminated.
15:12.36 
15:12.36 In the directory  /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dom/media
15:12.36 The following command failed to execute properly:
15:12.36 /usr/bin/ccache /usr/lib64/ccache/g++ -std=gnu++11 -o Unified_cpp_dom_media0.o -c -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/stl_wrappers -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/system_wrappers -include /mnt/to_archive/accum/src/mozilla-central/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DMOZILLA_INTERNAL_API -DWEBRTC_POSIX -DOS_POSIX=1 -DOS_LINUX=1 -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/mnt/to_archive/accum/src/mozilla-central/dom/media -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dom/media -I/mnt/to_archive/accum/src/mozilla-central/caps -I/mnt/to_archive/accum/src/mozilla-central/dom/base -I/mnt/to_archive/accum/src/mozilla-central/dom/camera -I/mnt/to_archive/accum/src/mozilla-central/layout/generic -I/mnt/to_archive/accum/src/mozilla-central/layout/xul -I/mnt/to_archive/accum/src/mozilla-central/netwerk/base -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/ipc/ipdl/_ipdlheaders -I/mnt/to_archive/accum/src/mozilla-central/ipc/chromium/src -I/mnt/to_archive/accum/src/mozilla-central/ipc/glue -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/nspr -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/mozilla-config.h -MD -MP -MF .deps/Unified_cpp_dom_media0.o.pp -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wc++14-compat -Wno-invalid-offsetof -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -pthread -pipe -g -Wall -fno-schedule-insns2 -fno-lifetime-dse -fno-delete-null-pointer-checks -O3 -fomit-frame-pointer -Wno-error=attributes -Wno-error=shadow /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-pc-linux-gnu/dom/media/Unified_cpp_dom_media0.cpp
15:12.36 /mnt/to_archive/accum/src/mozilla-central/config/rules.mk:934: recipe for target 'Unified_cpp_dom_media0.o' failed
15:12.36 gmake[5]: *** [Unified_cpp_dom_media0.o] Error 1
15:12.36 gmake[5]: *** Waiting for unfinished jobs....
likely a trivial fix
Rank: 22
Component: Audio/Video → Audio/Video: MediaStreamGraph
Priority: -- → P2
Whiteboard: [good-first-bug]
Comment on attachment 8773923 [details]
Bug 1284726 - move MediaStreamTrackEvent.webidl back out of MOZ_WEBRTC (used in gUM).

Looks like Bug 1181262 mistakenly moved MediaStreamTrackEvent.webidl and now we're using it in the mediacapture implementation. Please give this patch a try.
Flags: needinfo?(mats)
Flags: needinfo?(mats) → needinfo?(rforbes)
Comment on attachment 8773923 [details]
Bug 1284726 - move MediaStreamTrackEvent.webidl back out of MOZ_WEBRTC (used in gUM).

https://reviewboard.mozilla.org/r/66556/#review63338
Attachment #8773923 - Flags: review?(rjesup) → review+
Pushed by jbruaroey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bbc13c4c5928
move MediaStreamTrackEvent.webidl back out of MOZ_WEBRTC (used in gUM). r=jesup
https://hg.mozilla.org/mozilla-central/rev/bbc13c4c5928
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Flags: needinfo?(rforbes)
Assignee: nobody → jib
Duplicate of this bug: 1285283
You need to log in before you can comment on or make changes to this bug.