Closed Bug 1284852 Opened 4 years ago Closed 1 year ago

Color format change does not work as toggle in the Rules view, if default color unit is not "As Authored"

Categories

(DevTools :: Inspector: Rules, defect, P2)

48 Branch
defect

Tracking

(firefox47 unaffected, firefox48 wontfix, firefox49 wontfix, firefox-esr45 unaffected, firefox50 wontfix, firefox-esr60 wontfix, firefox64 wontfix, firefox65 verified)

VERIFIED FIXED
Firefox 65
Tracking Status
firefox47 --- unaffected
firefox48 --- wontfix
firefox49 --- wontfix
firefox-esr45 --- unaffected
firefox50 --- wontfix
firefox-esr60 --- wontfix
firefox64 --- wontfix
firefox65 --- verified

People

(Reporter: magicp.jp, Assigned: pbro)

References

(Regressed 1 open bug)

Details

(Keywords: regression, Whiteboard: [dt-q])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160705030222

Steps to reproduce:

1. Start Nightly
2. Go to any sites (e.g. about:home)
3. Open DevTools > Inspector
4. Changing the color format (Shift + click) in the Rules view  >  It works
5. Change the default color unit from  "As Authored" to any other units in the Toolbox Options
6. Changing the color format again in the Rules view


Actual results:

In step 6, the first click works, but it does not work from next clicks as toggle.

Regression range:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=712a70746d183ee33e00bc06efd48de25b7332a7&tochange=ad16491227f9cdf08fda7a3c1973562497d0f4ef


Expected results:

Color format change (shift + click) works as toggle in the Rules view, even if default color unit is not "As Authored".
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Developer Tools: Inspector
OS: Unspecified → All
Hardware: Unspecified → All
This is a regression.
In the regression range provided in comment 0, bug 1259559 seems like the culprit.
Keywords: regression
Inspector bug triage (filter on CLIMBING SHOES).
Priority: -- → P2
Blocks: 1259559
Version: Trunk → 48 Branch
Component: Developer Tools: Inspector → Developer Tools: CSS Rules Inspector
Product: Firefox → DevTools
Duplicate of this bug: 1507774
Whiteboard: [dt-q]
Assignee: nobody → pbrosset
Status: NEW → ASSIGNED
Pushed by pbrosset@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c0bf8772040
Part 1 - Set the used unit when appending a color to the rule-view; r=miker
https://hg.mozilla.org/integration/autoland/rev/c0345b057f11
Part 2 - Augment the color cycling test to also check cycling after a diffent type as chosen; r=miker
https://hg.mozilla.org/integration/autoland/rev/eeddd827762d
Part 3 - Re-format/factor browser_rules_cycle-color.js so it's easier to read; r=miker
Flags: qe-verify+

I’ve reproduce this issue with an affected Nightly - 65.0a1 (2018-11-08) on Windows 10 x64.
The issue is no longer reproducible with the latest Beta - 65.0b12 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1542734
You need to log in before you can comment on or make changes to this bug.