Cancel/OK cross-folder navig dialog loses foreground focus for mail window.

VERIFIED DUPLICATE of bug 122765

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 122765
16 years ago
13 years ago

People

(Reporter: laurel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({regression})

Trunk
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using mar01 commercial trunk, win98
Could not reproduce in linux, mac OS 10.1


When cancelling a cross-folder navigational confirmation dialog which was
initiated from a thread pane focus, the dialog closes and you're left in the
browser window (or in other application/window if no browser open).

1.  Open a mail folder or newsgroup which has no unread in the immediate
folder/group, but there are other folders/groups with unread messages.
2.  Select message in thread pane (may have to select folder then back to thread
pane because of regression bug 127144), click Next button.
3.  Cancel the "advance to next unread message in..." confirmation dialog.

Result:  mail window loses its foreground focus, user left in open browser or
other window/app.
(Reporter)

Updated

16 years ago
QA Contact: esther → laurel
(Reporter)

Comment 1

16 years ago
This happens when OK to the dialog, too. 
Summary: Cancel cross-folder navig dialog loses foreground focus for mail window. → Cancel/OK cross-folder navig dialog loses foreground focus for mail window.
(Reporter)

Comment 2

16 years ago
Does not happen using yesterday's (feb28) trunk build. Regression.
Nominating since it's a hassle to have to switch back to mail window when trying
to navigate.
Keywords: nsbeta1, regression
Bug 122765 reopened today,  same issue.

*** This bug has been marked as a duplicate of 122765 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.