Closed Bug 1285366 Opened 8 years ago Closed 8 years ago

Daily hangs on start

Categories

(Thunderbird :: General, defect)

50 Branch
Unspecified
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1284677

People

(Reporter: ~, Unassigned)

References

()

Details

(Keywords: hang)

Attachments

(1 file)

Attached file Sample of Daily.txt
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160630123429

Steps to reproduce:

After update to macOS Sierra Developer Beta 2 Daily hangs on start. I used to run Daily builds on Beta 1.


Actual results:

When started from the Dock the icon bounces for a while but then it stops. No running indicator appears under the icon. In the Activity Monitor Daily process is present and consumes 99% of CPU.

When ran from terminal it outputs the following and hangs.

> thunderbird(4058,0x7fffbdfda3c0) malloc: *** malloc_zone_unregister() failed for 0x7fffbdfd1548

I tried nightly builds all the way back to 42.0a1 starting with today's (50.0a1 (2016-07-07)). All the hang in the same way.
This doesn't happen to release versions. 45.2.0 runs fine.

macOS Sierra 10.12 Developer Beta 2 (16A239j).
OS: Unspecified → Mac OS X
Does it also happen in safe mode?  https://support.mozilla.org/en-US/kb/safe-mode
Yes. Both when starting with Option key from the dock and with --safe-mode switch on the command line.

Maybe it would help, I can not even get help with --help switch on command line.
I don't pretend to know anything about the state of stability and Macs, but perhaps related to bug 1284677?
Keywords: hang
Indeed, looks very similar by description. Likely the same issue.
Please reopen if bug 1284677 turns out to not resolve your problem
Severity: normal → major
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Component: Untriaged → General
Resolution: --- → DUPLICATE
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #5)
> Please reopen if bug 1284677 turns out to not resolve your problem

That bug is now fixed. Is your problem gone with today's daily?
Flags: needinfo?(cheba)
Yes, this problem has gone. Thanks.

It crashes now on start. Crash reports for that has been collected and sent.
Flags: needinfo?(cheba)
(In reply to cheba from comment #7)
> It crashes now on start.

I filed bug 1286613 about the crash.
List of crashes:

* bp-ce17ac14-4ff6-4646-9ce9-f82302160713
* bp-4911c941-17b5-4de9-b07f-1f69f2160713
* bp-8e2de7da-826f-478a-ab90-64d142160713
* bp-81d29dc7-a642-4576-84cc-713402160713

I don't know if any of those are related to this issue or its fix or not.
You need to log in before you can comment on or make changes to this bug.