Closed Bug 1285642 Opened 4 years ago Closed 3 years ago

[Ubuntu] Search Pop-up add new search engine area is too dark

Categories

(Firefox :: Theme, defect, P2, minor)

48 Branch
All
Linux
defect

Tracking

()

VERIFIED FIXED
Firefox 50
Tracking Status
firefox47 --- unaffected
firefox48 --- verified
firefox49 --- verified
firefox50 --- verified

People

(Reporter: Kwan, Assigned: dao)

References

Details

(Keywords: regression, Whiteboard: [fxsearch])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1275700 +++

In bug 1275700 the search pop-up was fixed to have a light background, but the `Add "{$engineName}"` section was missed and is still dark due to searchbar.css:

https://dxr.mozilla.org/mozilla-central/rev/23dc78b7b57e/browser/themes/linux/searchbar.css#212
Component: Widget: Gtk → Theme
Product: Core → Firefox
Keywords: regression
Priority: P1 → P2
Version: Trunk → 48 Branch
Attached patch patchSplinter Review
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Attachment #8770892 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8770892 [details] [diff] [review]
patch

Review of attachment 8770892 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me
Attachment #8770892 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/72e511829606
Fix "add engine" button colors. r=gijs
https://hg.mozilla.org/mozilla-central/rev/72e511829606
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Comment on attachment 8770892 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1275700
[User impact if declined]: "add engine" part of the search popup looks out of place
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: very trivial fix, low risk
[String/UUID change made/needed]: none
Attachment #8770892 - Flags: approval-mozilla-beta?
Attachment #8770892 - Flags: approval-mozilla-aurora?
Comment on attachment 8770892 [details] [diff] [review]
patch

Review of attachment 8770892 [details] [diff] [review]:
-----------------------------------------------------------------

This patch fixes a UI regression. Take it in 48 beta 9 and aurora.
Attachment #8770892 - Flags: approval-mozilla-beta?
Attachment #8770892 - Flags: approval-mozilla-beta+
Attachment #8770892 - Flags: approval-mozilla-aurora?
Attachment #8770892 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
Reproduced with Firefox 48 beta 7 under Ubuntu 14.04 64-bit.
The issue is now fixed using Firefox 48 beta 9, latest DevEd 49.0a2 and latest Nightly 50.0a1 2016-07-19.
Depends on: 1299126
No longer depends on: 1299126
You need to log in before you can comment on or make changes to this bug.