product/channel filter not updated after adding a new rule or changing an existing one

RESOLVED FIXED

Status

Release Engineering
Balrog: Frontend
RESOLVED FIXED
a year ago
10 months ago

People

(Reporter: bhearsum, Assigned: Njira, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=js][good first bug])

(Reporter)

Description

a year ago
The Product/Channel drop down on the rules page is supposed to contain a list of all of products, and the product+channel combinations. This works fine on initial page load, but is not updated if a new rule is added, nor an existing one modified. It's relatively rare that we add a new product or channel, but this is an annoying papercut.
(Reporter)

Updated

a year ago
Whiteboard: [lang=js][good first bug]
(Assignee)

Updated

a year ago
Assignee: nobody → njirap
(Assignee)

Comment 1

a year ago
Hi Ben.

I am unable to reproduce this bug. When I add a new Rule I can see it in the appropriate filtered rules list. And when I update a Rule from a filtered list it is automatically removed as a member of the filtered list. Please advise on what this bug might be or from what angle it is.
(Reporter)

Comment 2

a year ago
(In reply to Njira from comment #1)
> Hi Ben.
> 
> I am unable to reproduce this bug. When I add a new Rule I can see it in the
> appropriate filtered rules list. And when I update a Rule from a filtered
> list it is automatically removed as a member of the filtered list. Please
> advise on what this bug might be or from what angle it is.

Everything works fine in the list of Rules themselves, but if you add or update a Rule to contain a new Product or Channel, that won't be available in the drop down. For example, I loaded the Rules page and added a rule with "AAA" as both the Product and Channel. Once added, the drop down in the top right did not change at all. When I reloaded the page, it add "AAA" and "AAA,AAA" entries in it.

Does that make sense?
(Assignee)

Comment 3

a year ago
Yes Ben I believe I understand. The dropdown should be updated to include new Product/Channel combinations.
(Reporter)

Comment 4

a year ago
(In reply to Njira from comment #3)
> Yes Ben I believe I understand. The dropdown should be updated to include
> new Product/Channel combinations.

That's right.

Comment 5

10 months ago
Commit pushed to master at https://github.com/mozilla/balrog

https://github.com/mozilla/balrog/commit/a23096f36fa474ac8df6c83d8f5abbea7c04f605
bug 1285975: product/channel filter not updated after adding/editting (#188). r=bhearsum
(Reporter)

Updated

10 months ago
Depends on: 1324850
(Reporter)

Comment 6

10 months ago
This is in production now, thanks Njira!
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.