Crash in nsJSContext::cycleCollection::Trace while attaching documents to an email - caused by dropbox

VERIFIED INVALID

Status

Thunderbird
Message Compose Window
--
critical
VERIFIED INVALID
2 years ago
2 years ago

People

(Reporter: Richard Leger, Unassigned)

Tracking

45 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-d8040878-e501-486a-b312-4ecf52160711.
=============================================================

End-user reported she was attaching documents to an email when Thunderbird crash occurred. After restarting Thunderbird, email was available in Draft with the two attachments.

Comment 1

2 years ago
What happens if the user turns off dropbox??
Found in https://crash-stats.mozilla.com/report/index/d8040878-e501-486a-b312-4ecf52160711#modules
Ø DropboxExt.34.dll 	1.0.0.34	6C97524677FC484A8797E562568F5D421	dropbox_shell_ext.pdb
Wpc.dll 	1.0.0.1	58C99D979ADA4CD795F8740CE23C2E1F2	Wpc.pdb
xmllite.dll 	1.3.1001.0	2A7A661DFDDA4DB98ACC43DC56705DFC2	XmlLite.pdb
usp10.dll 	1.626.7601.19054	7B61100BF4BD4A1AA3F90DC9ED55237B1	usp10.pdb

(In reply to Richard Leger from comment #0)
> This bug was filed from the Socorro interface and is 
> report bp-d8040878-e501-486a-b312-4ecf52160711.
> =============================================================
> 
> End-user reported she was attaching documents to an email when Thunderbird
> crash occurred. After restarting Thunderbird, email was available in Draft
> with the two attachments.

 0 	xul.dll	nsJSContext::cycleCollection::Trace(void*, TraceCallbacks const&, void*)	dom/base/nsJSEnvironment.cpp:695
1 	xul.dll	`anonymous namespace'::SyncRunnable5<nsIStreamListener, nsIRequest*, nsISupports*, nsIInputStream*, unsigned __int64, unsigned int>::Run()	c:/builds/moz2_slave/tb-rel-c-esr45-w32_bld-0000000/build/mailnews/imap/src/nsSyncRunnableHelpers.cpp:250
2 	xul.dll	nsThread::ProcessNextEvent(bool, bool*)	xpcom/threads/nsThread.cpp:972
3 	xul.dll	NS_ProcessNextEvent(nsIThread*, bool)	xpcom/glue/nsThreadUtils.cpp:297
4 	xul.dll	MessageLoop::RunHandler()	ipc/chromium/src/base/message_loop.cc:227
5 	xul.dll	doContent	parser/expat/lib/xmlparse.c:2546
6 	xul.dll	MatchesBrands	toolkit/components/mediasniffer/nsMediaSniffer.cpp:58
7 	networkexplorer.dll	SHCreateDefaultExtractIcon
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(richard.leger)
Summary: Crash in nsJSContext::cycleCollection::Trace → Crash in nsJSContext::cycleCollection::Trace while attaching documents to an email

Comment 2

2 years ago
ALso, the crash rate for this signature is virtually zero.  So if the cause is not found to be dropbox, then I would look to the list of open bug reports about crashes and attachments https://mzl.la/29S8XJS
(Reporter)

Comment 3

2 years ago
Thanks for your support. 

I can now see in the crash report online the red icon (Ø) in the module tab as you pointed out. I was not aware of this tab nor that the report would highlight issue in such way, it is good to know.

Following your recommendation end-user has now removed Dropbox application from the computer, hopefully that will sort the issue, I am fairly confident it will.

If crash occurs again, I'll have a look at the resource you pointed out.

Thanks again for your help much appreciated.
(Reporter)

Updated

2 years ago
Flags: needinfo?(richard.leger)

Comment 4

2 years ago
(In reply to Richard Leger from comment #3)
> ... 
> Following your recommendation end-user has now removed Dropbox application
> from the computer, 

Good results?
Flags: needinfo?(richard.leger)
(Reporter)

Comment 5

2 years ago
Yes. Sorted.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Updated

2 years ago
Status: RESOLVED → VERIFIED
Flags: needinfo?(richard.leger)
Summary: Crash in nsJSContext::cycleCollection::Trace while attaching documents to an email → Crash in nsJSContext::cycleCollection::Trace while attaching documents to an email - caused by dropbox
You need to log in before you can comment on or make changes to this bug.