Closed Bug 1286716 Opened 6 years ago Closed 6 years ago

Implement plane splitting (for OpenGL backend)

Categories

(Core :: Graphics, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: miko, Assigned: miko)

References

Details

(Keywords: feature, Whiteboard: gfx-noted)

Attachments

(1 file)

This bug is about integrating the changes from bug 1286412 and bug 1274673 to implement plane splitting for OpenGL backend.
Keywords: feature
Priority: -- → P3
Whiteboard: gfx-noted
This patch enables plane splitting flag for OpenGL compositor backend.
Comment on attachment 8819028 [details]
Bug 1286716 - Implement plane splitting (for OpenGL backend)

https://reviewboard.mozilla.org/r/98598/#review99598
Attachment #8819028 - Flags: review?(matt.woodrow) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f5c0b7682e2f
Implement plane splitting (for OpenGL backend) r=mattwoodrow
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f5c0b7682e2f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Just FYI, Mozregression is telling me that this is the cause for a webcompat issue where a CSS transition is finishing and then the content is vanishing (https://github.com/webcompat/web-bugs/issues/4284).
(In reply to Thomas Wisniewski from comment #7)
> Just FYI, Mozregression is telling me that this is the cause for a webcompat
> issue where a CSS transition is finishing and then the content is vanishing
> (https://github.com/webcompat/web-bugs/issues/4284).

Thank you so much for this. I am currently debugging a similar regression I noticed at http://www.simulationcurriculum.com, but this test case will make things a lot easier.

I will report back when I have more information.
Depends on: 1332070
Sorry to dredge this up, but it looks like this patchset broke Spotify (according to mozregression) on OSX and Linux, and I'm not 100% sure if it's something we were aware of (or still in the middle of fixing).

>Last good revision: a4ddb0dd052046a056271628a570d86152361245
>First bad revision: f5c0b7682e2ff43f9bbe7400dc0ec7d397f256b3
>Pushlog:
>https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a4ddb0dd052046a056271628a570d86152361245&tochange=f5c0b7682e2ff43f9bbe7400dc0ec7d397f256b3
>Looks like the following bug has the changes which introduced the regression:
>https://bugzilla.mozilla.org/show_bug.cgi?id=1286716
Depends on: 1335159
No longer depends on: 1335159
Depends on: 1335159
You need to log in before you can comment on or make changes to this bug.