UI to Configure hotkeys of extensions

RESOLVED DUPLICATE of bug 1303384

Status

defect
P3
normal
RESOLVED DUPLICATE of bug 1303384
3 years ago
6 months ago

People

(Reporter: bugzilla12345678, Assigned: designakt)

Tracking

49 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: triaged, URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140911151253

Steps to reproduce:

This is a suggestion. Chrome users can configure hotkeys for extensions (and override the hotkeys from addon)  chrome://extensions/configureCommands. I did not found this feature in Firefox. It seems like Firefox doesn't enable user to configure hotkeys at all. I suggest to change this.


Actual results:

I want user to be possible to overwrite webextension hotkeys. AFAIK there is not such feature in Addons configuration page.


Expected results:

Create a page, where user can change the default hotkeys in addons. The commands which does not have hotkeys assigned should be possible to obtain a shortcut from user.
(Reporter)

Updated

3 years ago
Severity: normal → major
Component: Untriaged → Preferences
OS: Unspecified → Windows XP
Priority: -- → P1
Hardware: Unspecified → x86

Updated

3 years ago
Severity: major → normal
Component: Preferences → WebExtensions: Frontend
Priority: P1 → --
Product: Firefox → Toolkit

Updated

3 years ago
Priority: -- → P3
Whiteboard: triaged

Updated

2 years ago
Assignee: nobody → mjaritz

Updated

2 years ago
Duplicate of this bug: 1320332

Comment 2

2 years ago
Andy McKay, as I can't edit the original of duplicate (well, I'm not sure how to call it otherwise) — please, edit the current bug by adding into its "Blocks" field 1215059.

Comment 3

2 years ago
Going to mark this as a duplicate of bug 1303384 even though your report was posted earlier, because the other is already linked with other bugs and has more followers. Thanks for having taken the efforts to post this report!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1303384

Updated

10 months ago
Product: Toolkit → WebExtensions

Comment 4

6 months ago
Related Bug: 1325692.
You need to log in before you can comment on or make changes to this bug.