move and refactor en-us binary sanity checks under new relpro sanity logic

RESOLVED DUPLICATE of bug 1304259

Status

enhancement
RESOLVED DUPLICATE of bug 1304259
3 years ago
3 years ago

People

(Reporter: mtabara, Assigned: mtabara)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Once new release promotion sanity logic ships in bug 1282959, it would be nice to move the sanity check regarding the en-us binaries (checksums, GPG verification, etc) that's currently lying in release-runner.py to the new location under kickoff/sanity.py module. 

That way, the code in release-runner will be much cleaner with all of its (additional) logic moved under kickoff module.
(Assignee)

Comment 1

3 years ago
This in an excerpt from https://bugzilla.mozilla.org/show_bug.cgi?id=1256070#c5

---
While shipping 48.0b9 we found that add-on-devel builds were overriding win*-opt build indexes and those builds have not checksums, see bug 1287665. However, the message is misleading. Probably we should rearrange the code to get rid of UnboundLocalError.
---
See Also: → 1287665
Summary: move en-us binary sanity checks under new relpro sanity logic → move and refactor en-us binary sanity checks under new relpro sanity logic
(Assignee)

Comment 2

3 years ago
Will add this to my low-priority queue as it doesn't affect main functionality.
Will take care of it as soon as I have some time to spare.
Severity: normal → enhancement
(Assignee)

Comment 3

3 years ago
When migrating the code under kickoff sanity script, would be nice to rewrite part of the existing code base to be more clean and neat.

Sample:

---
Traceback (most recent call last):
  File "release-runner.py", line 413, in main
    validate_graph_kwargs(queue, gpg_key_path, **kwargs)
  File "release-runner.py", line 225, in validate_graph_kwargs
    sanitize_en_US_binary(queue, task_id, gpg_key_path)
  File "release-runner.py", line 190, in sanitize_en_US_binary
    validate_signatures(checksums, signature, tempdir, gpg_key_path)
UnboundLocalError: local variable 'signature' referenced before assignment
2016-07-18 18:54:23,077 - DEBUG - Releasing lock: /builds/releaserunner/tools/buildfarm/release/.release-runner.lock
---
(Assignee)

Updated

3 years ago
See Also: → 1288573
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1304259
You need to log in before you can comment on or make changes to this bug.