Closed Bug 1287413 Opened 5 years ago Closed 5 years ago

Blank area visible at the bottom of the CSS pane

Categories

(DevTools :: Inspector, defect, P1)

50 Branch
defect

Tracking

(firefox47 unaffected, firefox48 unaffected, firefox49 unaffected, firefox50 verified)

VERIFIED FIXED
Firefox 50
Iteration:
50.4 - Aug 1
Tracking Status
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- verified

People

(Reporter: adalucinet, Assigned: Honza)

References

Details

(Keywords: regression, Whiteboard: [devtools-html])

Attachments

(1 file, 1 obsolete file)

[Affected versions]:
- latest Nightly 50.0a1

[Affected platforms]:
- Windows 10 64-bit
- Mac OS X 10.11.1
- Ubuntu 16.04 64-bit

[Steps to reproduce]:
1. Launch Firefox.
2. Open Inspector: Ctrl + Shift + C (for Windows & Ubuntu) or Cmd + Opt + C (for Mac OS X).
3. Click on 'Collapse pane' button.
4. Click on 'Dock to side of browser window'
5. Click on 'Expand pane' button.
6. Drag up the CSS pane

[Expected result]: 
- CSS pane is properly displayed.

[Actual result]: 
- Blank area displayed at the bottom of the CSS pane.

[Regression range]:
- Last good revision: 2f9e69c982f1e67887a1834b36ff0af4ababb3af
- First bad revision: 3db372da6fe108ddb0727003447f22c2483fb86d
- Pushlog: https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=2f9e69c982f1e67887a1834b36ff0af4ababb3af&tochange=3db372da6fe108ddb0727003447f22c2483fb86d
- Maybe this was regressed by bug 1259819? 

[Additional notes]:
- Screen recording: https://goo.gl/5wuiaH
QA Whiteboard: [qe-dthtml]
Keywords: regression
Whiteboard: [devtools-html][triage]
See Also: → 1287415
Flags: qe-verify+
Priority: -- → P2
QA Contact: alexandra.lucinet
Whiteboard: [devtools-html][triage] → [devtools-html]
This could be caused by bug 1287368
Let's retest as soon as it's fixed.

Honza
Depends on: 1287368
Attached patch bug1287413.patch (obsolete) — Splinter Review
@Patrick, these two lines have been introduced when implementing the (HTML) Sidebar (bug 1259819). They are clearly wrong causing this bug so, I am removing it.

Honza
Assignee: nobody → odvarko
Status: NEW → ASSIGNED
Attachment #8772723 - Flags: review?(pbrosset)
Attachment #8772723 - Flags: review?(pbrosset) → review+
Iteration: --- → 50.4 - Aug 1
Priority: P2 → P1
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/a6c528c3fe72
Avoid blank area in the Sidebar. r=pbro
Keywords: checkin-needed
I had to back this out for eslint failures: https://hg.mozilla.org/integration/fx-team/rev/3367c6049a4f1a7f94532da415bba9e5e348e883

 TEST-UNEXPECTED-ERROR | devtools/client/inspector/inspector-panel.js:1222:9 | 'sidePane' is defined but never used (no-unused-vars)
Flags: needinfo?(odvarko)
Attached patch bug1287413.patchSplinter Review
(In reply to Wes Kocher (:KWierso) from comment #4)
> I had to back this out for eslint failures:
> https://hg.mozilla.org/integration/fx-team/rev/
> 3367c6049a4f1a7f94532da415bba9e5e348e883
> 
>  TEST-UNEXPECTED-ERROR | devtools/client/inspector/inspector-panel.js:1222:9
> | 'sidePane' is defined but never used (no-unused-vars)
Ah, sorry, updated patch attached.

Honza
Attachment #8772723 - Attachment is obsolete: true
Flags: needinfo?(odvarko)
Attachment #8773150 - Flags: review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/7378c2265376
Avoid blank area in the Sidebar. r=pbro
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7378c2265376
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
I reproduced this issue using Fx 50.0a1, build ID: 20160718081125, on Window 10 x64.
I can confirm the fix on Fx 50.0a1, build ID: 20160725030248.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.