Closed Bug 1287415 Opened 6 years ago Closed 6 years ago

CSS pane is hidden when Dev Tools is docked to the right side of browser window

Categories

(DevTools :: Inspector, defect)

50 Branch
defect
Not set
normal

Tracking

(firefox47 unaffected, firefox48 unaffected, firefox49 unaffected)

RESOLVED DUPLICATE of bug 1287368
Tracking Status
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- unaffected

People

(Reporter: adalucinet, Unassigned)

References

Details

(Keywords: regression)

[Affected versions]:
- latest Nightly 50.0a1

[Affected platforms]:
- Windows 10 64-bit
- Mac OS X 10.11.1
- Ubuntu 16.04 64-bit

[Steps to reproduce]:
1. Launch Firefox.
2. Open Inspector: Ctrl + Shift + C (for Windows & Ubuntu) or Cmd + Opt + C (for Mac OS X).
3. Click on 'Dock to side of browser window'

[Expected result]: 
- CSS pane is properly displayed.

[Actual result]: 
- CSS pane is automatically hidden

[Regression range]:
- Last good revision: 2f9e69c982f1e67887a1834b36ff0af4ababb3af
- First bad revision: 3db372da6fe108ddb0727003447f22c2483fb86d
- Pushlog: https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=2f9e69c982f1e67887a1834b36ff0af4ababb3af&tochange=3db372da6fe108ddb0727003447f22c2483fb86d
- I think this was regressed by bug 1259819? Honza, any ideas?

[Additional notes]:
- Screen recording: https://goo.gl/q9ZFlT
- As a side effect after step 3, if Collapse/Expand pane button is pressed ⇒ CSS pane is completely blank - no entries displayed in Rules, Computed, Box Model, Animations nor Fonts.
QA Whiteboard: [qe-dthtml]
Flags: needinfo?(odvarko)
Whiteboard: [devtools-html][triage]
I can reproduce this. It's dup of bug 1287368

Honza
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(odvarko)
Resolution: --- → DUPLICATE
Duplicate of bug: 1287368
No longer blocks: devtools-html-2, 1259819
Whiteboard: [devtools-html][triage]
Clearing affected for 50 since the dupe is tracked there.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.