Reduce memory consumption of buildapi and pushlog tasks

RESOLVED DUPLICATE of bug 1312007

Status

P3
normal
RESOLVED DUPLICATE of bug 1312007
2 years ago
2 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
The memory consumption of the pughlog and buildapi ingestion tasks seems to have increased after bug 1280913 / bug 1281056 - to the point where on Heroku I had to switch from a P1 to a P2 dyno type (bug 1277304 comment 12).

There's probably some simple tweaks we can make to reduce this (and also perform some further cleanup from now not needing to use the TreeherderClient). (A P1 dyno has 512MB RAM and costs $25/month, a P2 1024MB RAM $50/month, so not worth spending too long fwiw.)
(Reporter)

Comment 1

2 years ago
Ah so when we were still submitting resultsets/jobs using the API, the datasource connections (and this the leaks) were happening on the webheads, whereas after they were on the workers.

-> this is the datasource leak.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1312007
You need to log in before you can comment on or make changes to this bug.