Closed Bug 1288107 Opened 3 years ago Closed 3 years ago

For users with only one other device, remove "All devices" from send page/link/tab menu

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 50
Tracking Status
firefox50 --- verified

People

(Reporter: rfeeley, Assigned: eoger)

Details

(Whiteboard: [send-tab])

Attachments

(1 file)

Most users who have multiple devices will only have two. We should only show "All devices" for users with more than two and remove any dividers as well.
Whiteboard: [send-tab]
Assignee: nobody → edouard.oger
Status: NEW → ASSIGNED
Comment on attachment 8773487 [details]
Bug 1288107 - Remove All Devices option in Send Tab to Device menu when we only have 1 other device.

https://reviewboard.mozilla.org/r/66234/#review63074
Attachment #8773487 - Flags: review?(markh) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/6df391343333
Remove All Devices option in Send Tab to Device menu when we only have 1 other device. r=markh
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6df391343333
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
I've reproduced the initial issue on Nightly 50.0a1 (2016-07-20): "All devices" option is displayed even if the user has 1 other device.

The "Send Tab to Device" ride the trains - please see bug 1297454 . Also, the "Send Tab to Device" is enabled on non-nightly builds from Firefox 52 - please see bug 1304534. 

In this case, I verified the bug on Nightly 50.0a1 (2016-07-26) and on latest Nightly 52.0a1 (2016-10-26): the issue is no longer reproducible: the "All devices" option is displayed only for users that have multiple (two or more) other devices. If the user has 1 other device, the "All devices" options isn't anymore displayed. 

Marking the issue as VERIFIED FIXED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.