The diff cannot be displayed on mozreview

RESOLVED DUPLICATE of bug 1281712

Status

RESOLVED DUPLICATE of bug 1281712
2 years ago
2 years ago

People

(Reporter: TYLin, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
I got an exception to display this patch.
https://reviewboard.mozilla.org/r/65910/diff/1#index_header


Traceback (most recent call last):
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/views.py", line 275, in get
    response = renderer.render_to_response(request)
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/renderers.py", line 56, in render_to_response
    return HttpResponse(self.render_to_string(request))
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/renderers.py", line 74, in render_to_string
    large_data=True)
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/djblets/cache/backend.py", line 295, in cache_memoize
    compress_large_data))
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/djblets/cache/backend.py", line 249, in cache_memoize_iter
    items = items_or_callable()
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/djblets/cache/backend.py", line 292, in <lambda>
    lambda: [lookup_callable()],
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/renderers.py", line 73, in <lambda>
    lambda: self.render_to_string_uncached(request),
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/renderers.py", line 87, in render_to_string_uncached
    request=request)
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/diffutils.py", line 429, in populate_diff_chunks
    chunks = list(generator.get_chunks())
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/chunk_generator.py", line 756, in get_chunks
    for chunk in super(DiffChunkGenerator, self).get_chunks(cache_key):
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/chunk_generator.py", line 107, in get_chunks
    large_data=True)
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/djblets/cache/backend.py", line 295, in cache_memoize
    compress_large_data))
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/djblets/cache/backend.py", line 249, in cache_memoize_iter
    items = items_or_callable()
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/djblets/cache/backend.py", line 292, in <lambda>
    lambda: [lookup_callable()],
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/chunk_generator.py", line 106, in <lambda>
    lambda: list(self.get_chunks_uncached()),
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/chunk_generator.py", line 802, in get_chunks_uncached
    for chunk in self.generate_chunks(old, new):
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/chunk_generator.py", line 236, in generate_chunks
    yield self._new_chunk(lines, 0, num_lines, False, tag, meta)
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/chunk_generator.py", line 570, in _new_chunk
    compute_chunk_last_header(lines, num_lines, meta, self._last_header)
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/ReviewBoard-2.5.4.moz-py2.6.egg/reviewboard/diffviewer/chunk_generator.py", line 843, in compute_chunk_last_header
    line = lines[0]
IndexError: list index out of range
(Reporter)

Comment 1

2 years ago
The diff in comment #0 is a reduce test case from part 1a for bug 1277129.  I notice that nsHTMLReflowState.h has a blank line at the end of the file.  If I delete that blank line, the diff can be displayed properly as in https://reviewboard.mozilla.org/r/65870/diff/1#index_header
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1281712
You need to log in before you can comment on or make changes to this bug.