IRC changes nick to "undefined" when private message person changes nick

RESOLVED WORKSFORME

Status

Thunderbird
Instant Messaging
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: Jamie_, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
when using Thunderbird irc if you are private messaging someone if they change their nick while messaging them thunderbird gets confused and sets nick to undefined and you can no longer message that person until you restart Thunderbird. If it is a set contact that is setting nick as something different it sets it as undefined and moves contact to offline, if they go from a different nick to the defined contact it goes to "undefined undefined" and puts the contact into online contacts that you can click on to open history but cannot start conversation.

STR: 
1) set a nick as contact
2) start private message with contact
3) have person change nick
4) observe how Thunderbird treats the nick change

expected result:
If nick is changed to contact list contact it shows them as that contact and moves it from off line to you current conversation. If they change to a different nick from contact name should move contact name to off line and move conversation under new nick and still be able to send message.

actual result: 
if nick is changed its set to "undefined undefined" and cannot message the person until you restart Thunderbird.

I will add more details as i find them.
(Reporter)

Comment 1

2 years ago
Hey i see you are the module owner, can you take a look at this please and put it where it needs to go/to who it needs to go?
Flags: needinfo?(florian)
This seems to work OK in Instantbird, my guess is that this is a UI issue in Thunderbird and that this is the right component. Not sure why this would be happening though, maybe missing an observer.
Flags: needinfo?(florian)
Jamie, I can't reproduce this. What version of Thunderbird are you running? Can you check the error console and see if there are any errors appearing in there? Thanks!
Flags: needinfo?(charja13)
(Reporter)

Comment 4

2 years ago
im running on 45.2.0, i have been having this issue for a while now but just not got around to filing it. im gonna leave the ni on me so next time it happens i can check the error console and update this.
Jamie, are you still seeing this on newer versions of Thunderbird (hopefully you've updated to 45.7.0 now!) I'm not really sure what else to try to reproduce it. I'll try again though if you're still seeing this!
(Reporter)

Comment 6

a year ago
currently have not seen this issue in awhile. I will change this to works for me now.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(charja13)
Resolution: --- → WORKSFORME
Thanks for checking! :) Please feel free to re-open if you see this again.
You need to log in before you can comment on or make changes to this bug.