Changing review state in "Finish review" replaces content with HTML code in case of escaped strings are used

RESOLVED DUPLICATE of bug 1283024

Status

MozReview
Review Board: User Interface
RESOLVED DUPLICATE of bug 1283024
a year ago
a year ago

People

(Reporter: whimboo, Unassigned)

Tracking

Details

(Reporter)

Description

a year ago
Today I was working on the following review and added two links to the review text area. When I flipped the review state flags the content got replaced by HTML code.

https://reviewboard.mozilla.org/r/67108/#review63982

Here is what I did:
1. Open https://reviewboard.mozilla.org/r/67108/diff/1#index_header
2. Clicked on Finish at the top
3. Add a link to the text area, e.g. https://dxr.mozilla.org/mozilla-central/search?q=platformName+path%3Atesting%2Fpuppeteer&redirect=true
4. Switch the review state

You will see that the content gets replaced by using <p> tags. Also the text gets HTML encoded.

Sidenote: If you discard or close the review, and reopen it afterward the text seems to be encoded each time again and again. I was able to see it once.
Looks like we had this on file, although it's been reported a lot more in the recent days.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1283024
You need to log in before you can comment on or make changes to this bug.